Leap 15.6 Alpha/Beta Repositories?

Last year I did a fresh install of Leap 15.6 Alpha, and it had been running great, even through several large upgrades. But sometime in December (I think) my upgrade complained of unmet dependencies, so I figured I’d wait to see if it would get fixed later… I’m still on that build.

I see now that zypper is complaining about several expired repositories. I can’t find any documentation about what they are supposed to be. Can anybody help point me in the right direction?

the output of zypper repos -u is:

#  | Alias                                 | Name                                                                                        | Enabled | GPG Check | Refresh | URI
 1 | Mozilla                               | Mozilla                                                                                     | Yes     | (r ) Yes  | Yes     | https://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.4/
 2 | ftp.gwdg.de-openSUSE_Leap_$releasever | Packman Repository                                                                          | Yes     | (r ) Yes  | Yes     | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.6/
 3 | openSUSE-Leap-15.6-1                  | openSUSE-Leap-15.6-1                                                                        | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/15.6/repo/oss/
 4 | repo-backports-debug-update           | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | No      | ----      | ----    | http://download.opensuse.org/update/leap/15.6/backports_debug/
 5 | repo-backports-update                 | Update repository of openSUSE Backports                                                     | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/15.6/backports/
 6 | repo-debug                            | Debug Repository                                                                            | No      | ----      | ----    | http://download.opensuse.org/debug/distribution/leap/15.6/repo/oss/
 7 | repo-debug-non-oss                    | Debug Repository (Non-OSS)                                                                  | No      | ----      | ----    | http://download.opensuse.org/debug/distribution/leap/15.6/repo/non-oss/
 8 | repo-debug-update                     | Update Repository (Debug)                                                                   | No      | ----      | ----    | http://download.opensuse.org/debug/update/leap/15.6/oss/
 9 | repo-debug-update-non-oss             | Update Repository (Debug, Non-OSS)                                                          | No      | ----      | ----    | http://download.opensuse.org/debug/update/leap/15.6/non-oss/
10 | repo-non-oss                          | Non-OSS Repository                                                                          | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/15.6/repo/non-oss/
11 | repo-openh264                         | Open H.264 Codec (openSUSE Leap)                                                            | Yes     | (r ) Yes  | Yes     | http://codecs.opensuse.org/openh264/openSUSE_Leap/
12 | repo-oss                              | Main Repository                                                                             | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/15.6/repo/oss/
13 | repo-sle-debug-update                 | Update repository with debuginfo for updates from SUSE Linux Enterprise 15                  | No      | ----      | ----    | http://download.opensuse.org/debug/update/leap/15.6/sle/
14 | repo-sle-update                       | Update repository with updates from SUSE Linux Enterprise 15                                | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/15.6/sle/
15 | repo-source                           | Source Repository                                                                           | No      | ----      | ----    | http://download.opensuse.org/source/distribution/leap/15.6/repo/oss/
16 | repo-update                           | Main Update Repository                                                                      | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/15.6/oss
17 | repo-update-non-oss                   | Update Repository (Non-Oss)                                                                 | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/15.6/non-oss/

and to add: the two expired repos are:

Warning: Repository 'Update repository of openSUSE Backports' metadata expired since 2023-09-29 04:08:32 CDT.
Warning: Repository 'Update Repository (Non-Oss)' metadata expired since 2023-09-21 07:47:58 CDT.

and if I try a dup now, the first set of problems is:

Problem: nothing provides 'librav1e.so.0.6()(64bit)' needed by the to be installed vlc-beta-20240119.d8f9556dae-150600.15.pm.7.aarch64
Problem: the to be installed kwin5-5.27.9-bp156.1.6.aarch64 requires 'Mesa-libEGL1 >= 23.2.1', but this requirement cannot be provided
Problem: the installed Mesa-22.3.5-150600.76.pm.6.aarch64 requires 'Mesa-libEGL1 = 22.3.5', but this requirement cannot be provided

What specific message are you getting that shows the expired repository “complaints”? That would be useful information to see as well.

I realized that right after posting and edited my post, but not before your quick reply

1 Like

You should use zypper up to update Leap, not zypper dup. That might account for the second issue.

I see the metadata expiration messages on my test VM as well - so it’s not just you. Running a zypper up still seemed to do a complete update (for me, it didn’t result in a broken system at least).

Maybe someone else will have some insights into why the repo metadata for those two repos is outdated.

As far as I know, those repos are not actually used until close to the final release. So their timestamps are never updated until around release time. I just ignore those messages.

I do use “zypper dup” during the test phase, and revert to “zypper up” after the actual release.

That could be - I’ve asked on the factory ML to confirm, but that would make sense.

A week ago I tried the upgrade again, going through all the issues and solving most of them by switching from packman to openSUSE, but when I rebooted it dumped me to a command prompt. Is anyone else using Packman with the alpha version? Is it recommended?

I have had to switch packman packages back to the openSUSE repos. Otherwise the graphic session doesn’t start.

I just tried again, and same thing. These are the changes I chose:

The following 10 packages are going to change vendor:
  libvlc5       http://packman.links2linux.de -> openSUSE
  libvlccore9   http://packman.links2linux.de -> openSUSE
  Mesa          http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
  Mesa-dri      http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
  Mesa-gallium  http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
  Mesa-libEGL1  http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
  Mesa-libGL1   http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
  vlc           http://packman.links2linux.de -> openSUSE
  vlc-noX       http://packman.links2linux.de -> openSUSE
  vlc-qt        http://packman.links2linux.de -> openSUSE

Looking more into it I see the error “sddm failed to read display number from pipe”. I tried restarted sddm and deleting the xorg.conf.d file, but no luck. I’m currently thinking its an issue with some of my graphics libraries that are still on the packman version?

When I had added the Packman repo, I had done a command to upgrade all available files to the packman version. is there an opposite command?

… not sure if this is the right way, but I changed the priority of the packman repo with the command:
zypper mr -p 99 2 (2 being the # for the packman repo)
and then did a zypper dup --allow-vendor-change
And it flagged these additional package changes:

The following 5 packages are going to be upgraded:
  Mesa-libglapid Mesa-libua kmozillahelper libgbm1 mozilla-nss-certs

The following 2 packages are going to be downgraded:
  MozillaFirefox-branding-openSUSE mozilla-nspr

The following 7 packages are going to change vendor:
  Mesa-libglapio					http://packman.links2linux.de -> SUSE LLC https://www.suse.com/>
  Mesa-libva						http://packman.links2linux.de -> SUSE LLC https://www.suse.com/>
  MozillaFirefox-branding-openSUSE	openSUSE -> obs://build.opensuse.org/mozilla
  kmozillahelper					openSUSE -> obs://build.opensuse.org/mozilla
  libgbml							http://packman.links2linux.de -> SUSE LLC https://www.suse.com/>
  mozilla-nspr						SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/mozilla
  mozilla-nss-certs					SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/mozilla

I rebooted and I’m back!

When do you think it would be safe to switch back to the packman repo? (for greater codec support)

I used:

zypper dup --from repo-oss --allow-vendor-change

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.