Leap 15.5 Black Screen after auto-suspend in VMWare Workstation 17.02

Hi, I’m having some issues with Leap 15.5 on a VM, I downloaded an offline image of OpenSUSE Leap 15.5 and deployed it on VMWare WorkStation 17.02. When I installed it, I found that it would only install properly if 3D acceleration was turned off.

After that everything is fine with the system, but when I connect to the Leap with SSH (using XShell) I find that after about 10 minutes SSH disconnects (I have the Keep-alive option turned on). When I went back to the VM, I found that the VM was completely blacked out, no GUI, no ability to switch to the character console, no response to any input, and I had to reboot. I’m guessing that there might be a problem with KDE’s automatic logout.

I have no experience with system administration, but I tried to look at the system logs in YaST, and the SSH client reported the connection disconnected at the same time as the system went into suspend state.

I don’t have any ideas as to what went wrong, my current solution is to turn off automatic Suspend directly in the KDE power management settings, which seems to have solved the problem, if anyone has encountered a similar situation or has any troubleshooting ideas, appreciated.

2023-09-17T00:33:33.632752+08:00 localhost dbus-daemon[711]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by ':1.8' (uid=0 pid=904 comm="/usr/sbin/NetworkManager --no-daemon ")
2023-09-17T00:33:33.646622+08:00 localhost systemd[1]: Starting Network Manager Script Dispatcher Service...
2023-09-17T00:33:33.657697+08:00 localhost kded5[1581]: org.kde.plasma.nm.kded: Unhandled active connection state change:  3
2023-09-17T00:33:33.667884+08:00 localhost dbus-daemon[711]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
2023-09-17T00:33:33.668283+08:00 localhost systemd[1]: Started Network Manager Script Dispatcher Service.
2023-09-17T00:33:33.673345+08:00 localhost plasmashell[1655]: plasma-pk-updates: Is net mobile: false
2023-09-17T00:33:33.673411+08:00 localhost plasmashell[1655]: plasma-pk-updates: Is net online: false
2023-09-17T00:33:33.673433+08:00 localhost plasmashell[1655]: plasma-pk-updates: Is net online: false
2023-09-17T00:33:33.681544+08:00 localhost plasmashell[1655]: plasma-pk-updates: Is net online: false
2023-09-17T00:33:33.682449+08:00 localhost plasmashell[1655]: message repeated 2 times: [ plasma-pk-updates: Is net online: false]
2023-09-17T00:33:33.683529+08:00 localhost avahi-daemon[708]: Withdrawing address record for fe80::20c:29ff:fe76:90da on eth0.
2023-09-17T00:33:33.683620+08:00 localhost plasmashell[1655]: plasma-pk-updates: Daemon changed
2023-09-17T00:33:33.683666+08:00 localhost avahi-daemon[708]: Leaving mDNS multicast group on interface eth0.IPv6 with address fe80::20c:29ff:fe76:90da.
2023-09-17T00:33:33.683685+08:00 localhost avahi-daemon[708]: Interface eth0.IPv6 no longer relevant for mDNS.
2023-09-17T00:33:33.988406+08:00 localhost avahi-daemon[708]: Files changed, reloading.
2023-09-17T00:33:33.988841+08:00 localhost avahi-daemon[708]: No service file found in /etc/avahi/services.
2023-09-17T00:33:34.133881+08:00 localhost ModemManager[799]: <info>  [sleep-monitor] system is about to suspend
2023-09-17T00:33:34.293453+08:00 localhost avahi-daemon[708]: Withdrawing address record for on eth0.
2023-09-17T00:33:34.293531+08:00 localhost avahi-daemon[708]: Leaving mDNS multicast group on interface eth0.IPv4 with address
2023-09-17T00:33:34.293556+08:00 localhost avahi-daemon[708]: Interface eth0.IPv4 no longer relevant for mDNS.
2023-09-17T00:33:34.353665+08:00 localhost chronyd[951]: Source offline
2023-09-17T00:33:34.370449+08:00 localhost PackageKit: get-updates transaction /137_ddeacacb from uid 1000 finished with success after 5856ms
2023-09-17T00:33:34.389229+08:00 localhost systemd[1]: Reached target Sleep.
2023-09-17T00:33:34.391588+08:00 localhost systemd[1]: Starting System Suspend...
2023-09-17T00:33:34.431917+08:00 localhost dns-dnsmasq.sh[11077]: <debug> NETWORKMANAGER_DNS_FORWARDER is not set to "dnsmasq" in /etc/sysconfig/network/config -> exit
2023-09-17T00:33:34.439765+08:00 localhost systemd-sleep[11084]: INFO: Skip running /usr/lib/systemd/system-sleep/grub2.sleep for suspend
2023-09-17T00:33:34.444062+08:00 localhost systemd-sleep[11076]: Entering sleep state 'suspend'...
2023-09-17T00:33:34.444653+08:00 localhost kernel: [ 1032.659533][T11076] PM: suspend entry (s2idle)


Given that the GUI is KDE Plasma, please bounce this off the KDE Plasma Forum – <https://discuss.kde.org/>.

  • You won’t need to be very lucky if, a KDE developer answers your post … :wink:

Thanks, I’ll probably do that later when I test further.