leap 15.2 boot in emergency mode, how to save /run/initramfs/rdsosreport.txt

Hi, I started this post
https://forums.opensuse.org/showthread.php/544357-leap-15-2-doesnt-boot-after-update-and-grub-shows-only-15-2/page2
12 sept 2020 but sorry I hadn’t many time to follow and give informations and nobody gives me solutions.
Now I’m using leap 15.1 (without updating becouse I havent only windows as backup system) but I would like to give to 15.2 another chance so I started this new post now that seems to have more time to follow it.

12 sept 2020 on my tuxedo infinity pro ssd disk=2Tb, processor=Intel Core i7-8565U, RAM=32Gb, with tri boot system (Leap 15.1, 15.2, windows10) I updated 15.2 and at reboot (with new kernel)
1)after boot
https://susepaste.org/3213118
it is not well readable but in the following reappear better
2)a grey screen with three dots appeared and I pressed “esc” and this appears
https://susepaste.org/73721925
ending with:

started forward password requests to plymouth directory watch

3)after a couple of minutes this appear
https://susepaste.org/98272427
ending with:

[TIME]timed out waiting for device…
[DEPEND] dependency failed for resume from hibernation using device…
[OK] reached target local file system (pre)

after another couple of minutes this appear
https://susepaste.org/79622232
that should be the same appeared in 1)after boot but better readable
that after a lot of [FAILED] end with:

generating “/run/initramfs/rdsosreport.txt”

entering emergency mode. exit the shell to continue.
type “journalctl” to view logs.
you might want to save “/run/initramfs/rdsosreport.txt” to a USB stick or /boot
after mounting them and attach it to a bug report.

give root password for maintenance
(or press control-D to continue):

6)I pressed control-D but failed
https://susepaste.org/56070257
with:

sulogin: cannot read /dev/tty: operation not permitted

7)so I gave root password:
https://susepaste.org/86075926
and it worked

I tryed to save /run/initramfs/rdsosreport.txt to attach in this post but I didn’t succeed.
how can I save /run/initramfs/rdsosreport.txt some where?
how can I have my leap 15.2 working again?
manythanks, pier :slight_smile:

If you had used CODE tags instead of QUOTE tags, what you put there after “ending with” would have shown when I quoted your reply.

We have seen similar issues before.

Check “/etc/default/grub”. Look for the string “resume=”. It should be identifying your swap partition. But if your swap partition was reformatted, then it’s UUID may have changed.

Once you reach a rescue shell prompt, you should be able to run blkid to identify available partitions, then mount one, such as one used as /boot or as /home, to copy rdsosreport.txt to. If no mountable partitions are found by blkid, insert an EXTx formatted USB storage, run blkid again, and you should find a mountable USB partition to mount and copy rdsosreport.txt to.

manythanks happy to know, I used QUOTE becouse it was my insertion reading the screen and not a true code coming from a copy paste from the system where I had used CODE…

/etc/default/grub in which partition I has to check? how can I check which of the two leap start grub?? or is better to press “e” during boot and see what is?

ok, I will try, but when I insert root password I don’t know where I am, in what folder I am, if I run ls nothing is issued, how can I know where I am?

You can use that method if you like. Scroll down to the line that begins “linux” or “linuxefi”, and look for a “resume=” parameter. Perhaps change that from

resume=some-weird-string

to

noresume

for the one boot and see if that fixes the problem for that boot.

Lost in space?

echo $PWD

…tryed but didn’t solved

rotfl!..very lost in deep space, manytanks it worked

…tryed but blkid only show the internal hard disk and not the ext3 usb disk, but it has been very useful becouse I can mount an ext3 partition of internal hard disk and save there

manythanks to alllol!, I succeed to save the report
https://susepaste.org/2364090
here is the text
https://susepaste.org/93658163

…now that the report is here, any suggestion on how to have my 15.2 working and solve the emergency mode??
manythanks :wink:

Just posted how to fix to your original Forum thread.

Good luck.

TSU