LEAP 15.1 - Gnome Desktop Hangs

90% of the time, when I wake my laptop back up, I have to do a alt+f2, r to do anything. Sometimes… it’s totally locked up and alt+f2 doesn’t work

Sometimes. it crashes and logs me out completely. Anything I was working on is gone.

Thought about upgrade to Leap 15.2, only a few more weeks of Leap 15.1 support?

What graphics is in the system and laptop model?

/sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"

Thanks for the quick response, Malcolm! I’ve got bitten jumping on to Linux platforms that aren’t ready yet. I intend to wait until support for 15.1 is shut down for three months or so before I switch to 15.2 (unless it turns out I HAVE to, to get something to work).

james@linux-gx1p:~> /sbin/lspci -nnk | egrep -A3 “VGA|Display|3D”
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108GLM [Quadro 1000M] [10de:0dfa] (rev a1)
Subsystem: Hewlett-Packard Company Device [103c:1631]
Kernel driver in use: nvidia
Kernel modules: nvidia_drm, nvidia

Sorry, laptop model is an HP EliteBook 8560w

And your running X11 and not Wayland?

Your installing the driver from the repositories for the GPU? Have you upgraded it to the 460.27.04 driver?

HAHA! I just realized… are you the same Malcolm that was helping me here:

I posted this here, because I felt like I was bugging you for too much help. :confused:

So, I think you already know, I THINK this install started off as SLED 15.1 Wayland, then I got kicked off of SLED, then OpenSUSE Wayland didn’t want to work right, Then we added the stuff for X11 and XFCE so that I could get XFE and it’s assorted bolt ons working.

Honestly… I’m not sure what DISTRO my system currently is set to, let alone which version od Gnome. I’ll be more than happy to do what you say is best, though. :slight_smile:

I DID do a batch of updates a couple of days ago, it just told me I had more updates today, but I haven’t looked at it yet. Here’s what I’m seeing in YAST:

Yup, it is :wink: No worries, but is really better in the other Forum since it’s is really SLE and not openSUSE :wink:

So you have an old driver. Ideally get the G05 driver, it is the correct one for your gpu, especially the newer one has lots of fixes…

I do think you will get a better result switching to the likes of Tumbleweed with that hardware, I use Tumbleweed as my daily desktop, SLED on my laptop :wink:

…I don’t see a G05, how do I get that? Do I need a different repo?

What about the Wayland thing, how do I switch that back to the optimal one?

Is there something else I should do to switch this from SLED to OpenSUSE?

Spoke too soon, I DO see the G05, so the question is, how do I switch to it without mucking up the whole thing?

When I clicked to install the G05, it offered to uninstall G04, so I’m going to try it and cross my fingers. If you don’t hear back, I crashed my desk…laptop. :frowning:

Yeah, yeah… now I’m stuck on a 640x480 desktop.

james@linux-gx1p:~> nvidia-settings

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system


Reinstall G04 driver, broke Linux. I’m in a snapshot now. Still on 640x480.

Found a snapshot with a standard sized desktop. Now what??


dmesg |grep -i nvidia

to see when/if Nvidia driver gets loaded. If the above returns nothing, then your G05 driver was not compiled with the kernel for some reason and running


with G05 driver installed may solve the problem/tell you what goes wrong during compilation.

Off to the side, I have compiled a set of instructions for setting up laptops with Nvidia cards using bumblebee (https://forums.opensuse.org/showthread.php/537906-Cuda-Nvidia-bumblebee-codecs-quot-safe-quot-way) but be warned no one is officially maintaining bumblebee but it still works for me.

@SJLPHI Thank you for that… but I’m currently in a system snapshot. Don’t I need to do something to get back to a the live version, to a recovery console or something? Currently it hangs on boot. It doesn’t open a GUI on f2 or f7, and the other tabs never let me log in. If I do the… what’s it called… last known good thingy? …it still hangs, but I can ctrl+alt+del to reboot. Discovered that ctrl+alt+delete works from the f10 console as well.

That’s the extent of what I can figure out what to do there. I’m extrmely thankful that I found these snapshots to try to make repairs in, but I have no clue how to do that.

I’ll post your requested info, but note that I AM currently in a snapshot. Also, note that I uninstalled the G05 when it was stuck in 640x480 mode, and when I reinstalled the G04 version, that’s when the desktop crapped out and broke it to the point it never completes startup.

linux-gx1p:/home/james # dmesg |grep -i nvidia
    0.000000] ACPI: SSDT 0x00000000BF7CB000 00187E (v01 HPQOEM NVIDIAGF 00000001 INTL 20060912)
    9.823677] nvidia: loading out-of-tree module taints kernel.
    9.823685] nvidia: module license 'NVIDIA' taints kernel.
    9.828259] nvidia: module verification failed: signature and/or required key missing - tainting kernel
    9.838083] nvidia: externally supported module, setting X kernel taint flag.
    9.839090] nvidia-nvlink: Nvlink Core is being initialized, major device number 238
    9.839398] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=io+mem
    9.839472] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  390.138  Thu May 14 01:01:53 PDT 2020 (using threaded interrupts)
    9.949131] nvidia_uvm: externally supported module, setting X kernel taint flag.
    9.951986] nvidia-uvm: Loaded the UVM driver in 8 mode, major device number 237
   10.075442] nvidia_modeset: externally supported module, setting X kernel taint flag.
   10.092045] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  390.138  Thu May 14 04:02:47 PDT 2020
   10.133846] nvidia_drm: externally supported module, setting X kernel taint flag.
   10.134513] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
   10.134515] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 0
   11.172467] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input21
   11.172530] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input22
   11.172588] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input23
   11.172646] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input24
linux-gx1p:/home/james #

linux-gx1p:/home/james # mkinitrd
Creating initrd: /boot/initrd-4.12.14-197.72-default
dracut: Executing: /usr/bin/dracut --logfile /var/log/YaST2/mkinitrd.log --force /boot/initrd-4.12.14-197.72-default 4.12.14-197.72-default
dracut: No permission to write to /boot.
Creating initrd: /boot/initrd-4.12.14-197.75-default
dracut: Executing: /usr/bin/dracut --logfile /var/log/YaST2/mkinitrd.log --force /boot/initrd-4.12.14-197.75-default 4.12.14-197.75-default
dracut: No permission to write to /boot.
update-bootloader: 2020-12-19 12:47:27 <3> update-bootloader-7527 run_command.294: '/usr/lib/bootloader/grub2/config' failed with exit code 1, output:
+ /usr/sbin/grub2-mkconfig -o /boot/grub2/grub.cfg
/usr/sbin/grub2-mkconfig: line 277: /boot/grub2/grub.cfg.new: Read-only file system
Updating bootloader failed
linux-gx1p:/home/james # 

I BET all of this has something to do with the fact that this started life as a SLED 15.1 install. If you read back through the posts, you’ll see where I mention that I added the OpenSUSE 15.1 repos, but I’m not at all sure which platfrom this currently is on, or even how to tell that.

dracut: No permission to write to /boot.

looks very worrying to me. Did you run the mkinitrd command as root? Also can you also share your /etc/fstab ?

More than happy to try anything, that doesn’t make it worse. As I said though, I’m currently working in a read-only system snapshot. I don’t think I CAN change anything. I THINK that first I need to figure out how to manipulate the live system, which currently won’t complete the boot process.

I DID try the mkinitrd command, the results are just above.

linux-gx1p:/home/james # cat /etc/fstab
UUID=4f687d3e-4d7b-4ba2-81f5-30f6ef92d015  /                       btrfs  defaults                      0  0
UUID=4f687d3e-4d7b-4ba2-81f5-30f6ef92d015  /boot/grub2/x86_64-efi  btrfs  subvol=/@/boot/grub2/x86_64-efi  0  0
UUID=4f687d3e-4d7b-4ba2-81f5-30f6ef92d015  /boot/grub2/i386-pc     btrfs  subvol=/@/boot/grub2/i386-pc  0  0
UUID=4f687d3e-4d7b-4ba2-81f5-30f6ef92d015  /.snapshots             btrfs  subvol=/@/.snapshots          0  0
UUID=4f687d3e-4d7b-4ba2-81f5-30f6ef92d015  /var                    btrfs  subvol=/@/var                 0  0
UUID=4f687d3e-4d7b-4ba2-81f5-30f6ef92d015  /usr/local              btrfs  subvol=/@/usr/local           0  0
UUID=4f687d3e-4d7b-4ba2-81f5-30f6ef92d015  /tmp                    btrfs  subvol=/@/tmp                 0  0
UUID=4f687d3e-4d7b-4ba2-81f5-30f6ef92d015  /srv                    btrfs  subvol=/@/srv                 0  0
UUID=4f687d3e-4d7b-4ba2-81f5-30f6ef92d015  /root                   btrfs  subvol=/@/root                0  0
UUID=4f687d3e-4d7b-4ba2-81f5-30f6ef92d015  /opt                    btrfs  subvol=/@/opt                 0  0
UUID=53b51811-5b8b-4154-966f-93319179ea7a  /home                   xfs    defaults                      0  0
UUID=4df1c4e1-b66a-4b3a-9cda-cc2e38d0377b  swap                    swap   defaults                      0  0
linux-gx1p:/home/james # 

I just discovered the command ‘snapper’ but I have no idea IF that will help me, let alone how.