Leap 15.1 Can't turn wireless on to scan for networks.

I’m new to Linux. I’ve just installed it alongside windows and first up was to get wireless working. I followed the sticky and established it as a wifiLink 5100 AGN [Shiloh] network LAN with kernal driver iwlwifi. Looks to have all the firmware installed when I ran a “dmesg | grep firmware” command. However, I tried to do a scan and it failed but I noticed the wifi symbol above the keyboard was orange and should be blue. I pressed it but it remains off. Had a hunt around in the settings to see where I can turn it on but can’t find where to do it. I’m falling at the first hurdle here. I tried a wired ethernet but when I tried to create a new connection I was required to set it up with stuff I have no clue about. Without an internet connection I can’t cut and paste reports to resolve issues. So first up. How do I turn wireless on so I can scan for my network. Obviously it has to be software as pressing the wireless symbol does nothing. Any help gratefully received. Ian

Please post:

/usr/sbin/rfkill list all
/sbin/lspci  -nnk | grep -iA3 net

I can’t cut and paste the result of the two commands but

first one.

0 : hp-wifi : wireless Lan

soft blocked : yes
hard blocked. : no

1 : phy0 : wireless Lan
soft blocked : yes
hard blocked. : yes

and second command

kernal in use iwlwifi
kernal modules iwlwifi

Incidentally, when I log back into windows the wifi has been turned off. How do I turn it on in Linux.

oh and ethernet controller r8169

For wireless devices that are only soft-blocked you can do

sudo rfkill unblock wifi

Hard-blocked devices may need a switch or key combo to enable.

What you can do for posting such info is to copy output to a text file and save to a memory stick, then post via an internet-connected PC.

Like I say. I’m very new to this. How would I format the USB stick to be able to be read by both Linux and Windows. Aren’t they different formats?

Biggest pain is shutting down and then logging into windows and getting wifi turned on again. Is there no easy way to turn on the wireless signal?

That didn’t seem to do anything. I knew Linux would be a learning curve but if it’s this difficult to turn on my wifi I’m not going to get out of the starting block am I. It’s a bog standard HP laptop and Suse seems to recognise the hardware.

Laptop model? In the past I have had laptops where the windows driver was taking steps to shutdown wireless and leaving the device disabled when booting into Linux.

Linux can cope with Windows proprietary formats such as vfat and ntfs filesystems.

Should I format the pendrive in Linux or Windows?

Either will do, but probably easier for you to do in a windows environment.

P7350 @ 2GHz
4Gb Ram
32 bit

None of that is relevant. What is the HP laptop model?

You should check your windows wifi adapter settings in windows and ensure that power management (or similar settings) are not enabled. That might be causing the wifi hardware to be disabled when rebooting in to Linux perhaps…
https://www.youtube.com/watch?v=k5kLeE2j-es

Also, check any relevant BIOS settings that might be causing this behaviour as well.

HP Pavilion dv5

It’s definitely something in the Linux boot sequence that’s turning it off because when I log back into windows the wifi has been turned off.

Hi
So is it hard blocked when you boot up? Sure there is no wifi switch present on the front edge? If you toggle the Fn+wifi key (F12 or maybe F3).

If you look at the boot log, can you see the wifi being enabled/disabled?


journalctl -b

On newer Dell BIOS - there is a setup for WIFI, WWAN, Bluetooth that allow no option to turn off or to disable each - I wonder if the HP BIOS has the same settings. If the default is off - Linux cannot turn it on - I found that out on one Dell I bought used that the WIFI would not work until I set the BIOS to enabled not switchable to off.

My two cents worth.

Yes, one of the possibilities that I wanted the OP to check back in post #15.