LEAP 15.0 codecs

I upgraded my machine from 13.1 to 15.0 yesterday. I did an install from scratch. I do realise 15.0 is not officially released yet, but I was wondering if there were codecs available (vlc-codecs, …)?

I assume that Packman will not have them available until short before (or even later) the release of 15.0.


It appears that are available.

It looks like there are

sudo zypper ar -f http://packman.jacobs-university.de/suse/openSUSE_Leap_15.0/ packman

Sorry, I did not check, I assumes that the OP did try to find the Packman repo and failed because it isn’t already there. After all he used Packman on his 13.1 for it.

Ok, thank you very much. Added the repository and did a vendor change for all vlc related stuff, seems to work now.

The idea is that you do a vendor change. Not only for “vlc related stuff”.

The idea is also that you do that after every installation. Thus my assumption that you did that for 31.1. Thus my assumption that you tried to do that for 15.0.

The installation of 13.1 has been a while now and I assume, at that time, I did all kinds of funky stuff with repositories, so I could get vlc-codecs to work. I tried to reproduce what I did back then and I got into a bunch of conflicts. Uninstalling vlc and related components, enabling packman and installing vlc again solved my problem.
You should know, I have been a Ubuntu user for quite some time, and started to use openSUSE again since 12.1 came out, I think. So I am still not very comfortable in the zypper installer … but I am getting there.
Thanks, again.