Leap 15.0 Can't configure network card on install

This is on a Raspberry Pi3 with Leap 15.0 and 4.12.14-lp150.12.79-default kernel;

T:  Bus=01 Lev=03 Prnt=04 Port=02 Cnt=01 Dev#=  5 Spd=480 MxCh= 0
D:  Ver= 2.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  2
P:  Vendor=0bda ProdID=8153 Rev=30.00
S:  Manufacturer=Realtek
S:  Product=USB 10/100/1000 LAN
S:  SerialNumber=000002
C:  #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=200mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=00 Driver=r8152

ip addr

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether xx:27:xx:8f:xx:a4 brd ff:ff:ff:ff:ff:ff
    inet xx.xxx.xxx.xxx/24 brd xx.xxx.xxx..255 scope global eth0
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 8c:ae:4c:ee:6d:ef brd ff:ff:ff:ff:ff:ff
4: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether b8:27:eb:da:78:f1 brd ff:ff:ff:ff:ff:ff

lsusb -t
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc2/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/5p, 480M
        |__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=smsc95xx, 480M
        |__ Port 4: Dev 4, If 0, Class=Hub, Driver=hub/4p, 480M
            |__ Port 3: Dev 5, If 0, Class=Vendor Specific Class, Driver=r8152, 480M

Add the option for the r8152 module at booting the install…

You have older chip version (also USB 2.1 and not USB 3.0). Version 0x6010 is RTL8153B; it is supported by upstream kernel starting with 4.13 and by Leap 15.0 kernel since about a year:

Tue Dec 18 12:05:27 CET 2018 - tiwai@suse.de
- r8152: support RTL8153B (bsc#1119749).

@OP: you do not need to “move to wifi zone”; you just need to download single kernel-default RPM from updates repository and install it manually. After that your adapter should work.

My problem with 15.1 is that when it tries to boot for the first time after install, it gets stuck at the “loading ramdisk” stage and never moves from there.

Immediately after the initial locale setting screen I am prompted to set up network connections, as both my devices are not configured. But there is no option to edit the eth0 device, only the wlan device. The “edit” button is greyed out for the ethernet device.

I have downloaded and installed




Installing it directly resulted with a message popping up to say “internal error”, but the status of the rpm changed to “installed”. However, a reboot and a following attempt to configure the network showed that nothing changed. The current kernel version is 4.12.14-lp150.11 .

I did another install with the parameter brokenmodules=r8152, but although the screen clearly displayed loading the r8152 driver for the Realtek r8153 device, once the installation was done I was unable to configure the network for use of eth0. The option to edit the Realtek device remains greyed out in network settings.

Not only is not this update repository, this is not even repository for Leap. No surprise you got an error installing it.


What makes you believe that installing the same kernel that does not support your Ethernet device over and over again will finally succeed?

Nothing, But as I was given different advice by various people I wanted to explore all avenues. Some of the replies I received implies that the module is in 15.0 and that the device should be supported. Clearly, I was wrong.

As for the kernel module I was trying to install, I was trying to find it without much knowledge of where to look. I would appreciate a pointer to the correct module and place from which to download it.

Should a non-kernel (usermode) driver be required,
Arvidjar’s post #26 has a link to what you probably need…
Hopefully you won’t have to blacklist the driver provided by the kernel for this driver to work…

Your 15.1 described problem may be caused by a faulty install image, run a checksum on the image (Can be checked externally, but most openSUSE install images provide an easy menu item which can be selected to do the check).

It’s curious that in your default install, it appears that a driver is loaded… likely provided by the kernel and you say that the NIC appears in YaST but is greyed out and unconfigurable…
Perhaps you should run a checksum check on your 15.0 installation media as well.


Problem solved: I have downloaded the additional module from the link provided kindly by arvidjar, and the system has access to the net.
Thanks for all the help, everybody.

Regarding 15.1, I have run a successful checksum on the iso and it is ok. I think that I saw some reports from other users soon after 15.1 came out, who had the same problem, though perhaps not in this forum. This may be something to do with the hardware: I have used the same iso to install 15.1 on a desktop computer and it works fine. A second desktop showed the same problem as my laptop. I am curious to know what the underlying reason is.

No, there was no driver loaded for the realtek USB device.

Thanks for the update. I had missed the fact that the device was a newer version (and had only noticed the product ID matching what the driver list). Anyway, not that you’re online, it would be good to consider an in situ upgrade to 15.1 (or even 15.2 when the time comes).

If I upgrade to 15.1 in situ (not that I know how to do this yet) am I not running the risk of the same problem I had when I tried a direct install of 15.1? Namely, “loading initial ramdisk” gets stuck and nothing more happens.

My thinking is that will likely be installer-related, and that in this case you’re doing a ‘zypper dup’ (with Leap 15.1 repos) to upgrade packages on an already installed system. Let’s see what others advise here. (Leap 15.0 will be EOL soon.)

I updated Leap 15.0 today. And I got that EOL notice. It is already EOL.

Yep, all the more reason to upgrade ASAP.