Leap 15.0 Can't configure network card on install

I have had to install 15.0 (tried 15.1 but it is broken for my laptop model and won’t boot after install), but to my surprise I can’t configure the network card for wired connections (I don’t have wifi). The message is “Unable to configure the network card because the kernel device (eth0, wlan0) is not present.”
I am using the 15.0 iso image I downloaded today from the archived versions on the openSUSE site.

How do I get around this problem? I need to be able to download a fix but can’t access the network. And I don’t know what the fix is.


Pls post the name of your computer make and model, and the network card(s) in your system.


  • If you have access to another working computer at the same time, which can run any kind of OS (If you have access, a description for that, also).
  • Which installation ISO are you trying to use? Provide either the file name or if that isn’t convenient at least the size of the file which will minimally tell us whether it’s a DVD or a NET install ISO.


Computer: Acer TravelMate B-117
Network card: Gigabit RTL8153
The iso is
and I used a usb card to run the installation from.

I have a working desktop running Leap 15.1 as well.


Omission: make of the network card is Realtek


Just to clarify further, you’ve managed to install openSUSE 15.0 successfully on this laptop, but just don’t have a working ethernet device? If so, please get us the chipset details

/sbin/lspci -nnk|grep -iA3 net

You can save the output this to a text file and copy to a memory stick. Then post from an internet-connected machine.

02:00.0 Network controller [0280]: Intel Corporation Wireless 7265 [8086:095a] (rev 59)
Subsystem: Interl Corporation Dual BAnd Wireless-AC 7265 [8086:5010]
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi

But I don’t see how this relates to my USB-adapter for wired connection. This is the wifi information.


But I don’t see how this relates to my USB-adapter for wired connection. This is the wifi information.


Sorry, I missed that you were using a USB-connected ethernet device. Run this instead


The Realtek device that comes up gives this information:

T: Bus=02 Lev=01 Prnt=01 Port=04 Cnt=01 Dev#= 3 Spd=5000 MxCh= 0
D: Ver= 3.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 9 #Cfgs= 2
P: Vendor=0bda ProdID=8153 Rev=31.00
S: Manufacturer=Realtek
S: Product= USB 10/100/1000 LAN
S: SerialNumber=001000001
C: #Ifs= 2 Cfg#= 2 Atr=a0 MxPwr=288mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=02(Commc ) Sub=06 Prot=00 Driver=none
I: If#= 1 Alt= 0 #EPs= 0 Cls=0a(data ) Sub=00 Prot=00 Driver=none

Ok, so no driver loaded.

With openSUSE Leap 15.1 I note that the product ID for your device is reported as supprted…

 sudo modinfo r8152|grep 8153
description:    Realtek RTL8152/RTL8153 Based USB Ethernet Adapters
alias:          usb:v0BDAp8153d*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v0BDAp8153d*dc*dsc*dp*icFFisc*ip*in*

I don’t have openSUSE 15.0 installed, but perhaps you could run the same command to see if the kernel supports that particular chipset.

I get identical output to yours on 15.0.

So if the chipset is supported, why is the driver not loaded?

Not sure, but try loading it manually

sudo modprobe r8152

then see if a wired ethernet deivce node is present.

ip a

The other information which might be useful is to capture dmesg output after unplugging and re-plugging the device…

sudo dmesg |tail

There’s quite a lot of output.
I see the following references:
r8152 2-1:2.0: Unknown version 0x6010
and later:
usb 2-1: USB disconnect, device number 2
usb 2-1: New SuperSpeed USB device number 3 using xhci_hcd
usb 2-1: New USB device found, ideVendor=0bda, idProduct=8153
usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=6
usb 2-1: Product: USB 10/100/1000 LAN
usb 2-1: Manufacturer: Realtek
usb 2-1: Serial Number: 001000001
r8152: Unknown version 0x6010

After some other devices there is:
usb 2-1: USB disconnect, device number 3
usb 2-1: New SuperSpeed USB device number 4 using xhci_hcd

this is followed by the same text as above.

I did disconnect and reconnect twice, so this explains the duplication, but I still have no network access.

Sorry, lost track of the formatting. Some of my responses are inside your original quoted message.

Did you try loading the driver manually as suggested?

Yes, sudo modprobe r8152 worked without any error message.

Ok, now I see your responses embedded in my post reply.

Can you try connecting via a different USB port (assuming you have a mixture of USB 2.0 and USB 3.0 ports available)?

I have two port and used both, but I think they are both USB 3.0
At any rate, I think that the problem is in the kernel support rather than the hardware.

It looks like I will have to get the laptop to a wifi environment, do the many updates it will need anyway and hope that the later versions of the kernel that will be loaded during these updates will also be able to support my ethernet-USB connection properly.

I am a little surprised at this state of affairs: if kernel updates occur regularly, why isn’t the iso of this version being updated accordingly? It looks odd to have to go back to a very old kernel every time I need to reinstall the OS. And if the answer is that this why new versions come out, the next question is how 15.1 can be left as is for so long when it is clearly broken and won’t load on quite a few computers.

Anyway, thanks for your help. If my problem persists after wifi updates I will add to this thread.


First thing to note is that your Realtek card should be supported by both 15.1 and 15.0.
Since 15.0 is just now EOL, if you do succeed in installing 15.0 you would probably want to upgrade to 15.1 immediately to receive security patches.

So, although you weren’t specific why 15.1 wasn’t working for you,
I highly recommend trying 15.1 again and if it’s not working to pls post a more detailed description of what your problem is.

I assume, but you should verify that your USB Realtek is plugged in during the entirety of your installation.
When running the 15.1 install, one of the first things that happens after hardware detection is that Network Manager will prompt you to configure online repositories, does that happen?

And, when running the 15.0 install… Although you are not prompted to configure online resources, I’d recommend that you do so anyway when you are prompted to install a Desktop… It’s a good test to see if your NIC is recognized and working at that point or not And, if it’s not then it’d be interesting what error is returned.
So, for instance whether you ran modprobe or not, what have you done (or not) to try to configure the NIC? Do you have DHCP running on your network? Did you inspect your NIC in YaST?

Alternative, particularly in the 15.0 install is to inspect your YaST Network Service to see if your NIC is recognzed but for some reason unconfigured,
Since we don’t know what happened in 15.1, I can’t suggest a possible course of action if you can login.


@tsu2: Detection/Configuration is irrelevant when there is no driver loaded and/or said driver does not bind with device.