LCD brightness is really low

My screen brightness is really low. From the gnome settings, it shows that the brightness is full and my keyboard shortcut also shows it’s full but it actually is really dim so it’s hard to see text on the screen. Also, the mousepad clicking function doesn’t work. I can click on the button but clicking on the… how to call it… on the “pad” itself doesn’t work. I am really used to clicking on the pad itself and not using the buttons. What can I do to resolve these problems?

I have some… Intel integrated craphics-****-card. Mobile 4 family or smth.
The laptop itself is Samsung R410 plus.
System is openSUSE 14.11 Ggome 3 desktop.

From system settings somewhere I read:

Initializing Graphics with KMS (Kernel Mode Setting)
With openSUSE 11.3 we switched to KMS (Kernel Mode Setting) for Intel, ATI and NVIDIA graphics, which now is our default. If you encounter problems with the KMS driver support (intel, radeon, nouveau), disable KMS by adding nomodeset to the kernel boot command line. To set this permanently, add it to the kernel command line in /boot/grub/menu.lst. This option makes sure the appropriate kernel module (intel, radeon, nouveau) is loaded with modeset=0 in initrd, i.e. KMS is disabled.
In the rare cases when loading the DRM module from initrd is a general problem and unrelated to KMS, it is even possible to disable loading of the DRM module in initrd completely. For this set the NO_KMS_IN_INITRD sysconfig variable to yes via YAST, which then recreates initrd afterwards. Reboot your machine.
On Intel without KMS the Xserver falls back to the fbdev driver (the intel driver only supports KMS); alternatively, there is the "intellegacy" driver (xorg-x11-driver-video-intel-legacy package) which still supports UMS (User Mode Setting). To use it, edit /etc/X11/xorg.conf.d/50-device.conf and change the driver entry to intellegacy.
On ATI for current GPUs it falls back to radeonhd. On NVIDIA without KMS the nv driver is used (the nouveau driver only supports KMS).


Can you adjust the brightness from the integrated function of your laptop ?

No, you mean the button combination? No… it shows the icon on the screen and that I am changing it (the animation) but nothing actually changes.

What about in the BIOS? I know that Dell laptops have BIOS settings related to the LCD brightness.

Yeah, I checked the BIOS, it was auto there, I changed it to user controlled but it didn’t change anything. The auto thing was related to the part when you have the laptop on battery or connected to power … something. I don’t know the english word. Anyways, the thing is, when the computer launches the brightness is normal, in GRUB also but when it starts loading, it makes the screen dim. After some time it becomes even more dim. I checked the system settings and screen under there. There is an option to dim screen to save power and then after 10 minutes or whatever I choose. Shouldn’t it affect the laptop when I’m not using it. It seams it dim’s the screen after 10 minutes even if I’m using the laptop. Still… the screen is dim, after 10 minutes it just went even more dim.

You installed the GNOME 3 liveCD version, is that right ?

correct it is.

Before installing this version, you had wich version ? Did you have this problem ? It could be related to this untested version of openSUSE.

Before it I had Ubuntu 10.10. The brightness adjusting didn’t work there also but it didn’t matter because the screen was at it’s maximum brightness. Under windows 7, it works ok.

I have no clue for you.

The last thing I can tel you is that during next week, an official repo for the GNOME 3 desktop will be set up and maybe you should think about installing the actual GNOME 11.4 to see if you have this problem and upgrade your desktop to GNOME 3 once the repo is ready. This way, you’ll get a GNOME 3 version tested by the openSUSE devs and you’ll see if the problem persists.

whatabout the system I installed atm? Can’t I upgrade this or something? I’m not really keen on the idea to install it again. I had a hell of a trouble to get it installed :D:D

Can’t I upgrade my craphics drivers or smthing? What about the text I wrote in the first post the fallback drivers or smth? Can’t it affect it?

Don’t know for the graphic drivers you said, but I think you should be able to change the version of the actual GNOME 3 packages when the new repo will be available next week. You’ll have to first delete the one that is already installed on your media source and replace it with this new one. After that, you’ll do a package switch in yast.

Okay. Now… I put nomodeset in the boot menu file. So, it uses the fallback graphics driver. This made my resolution fck up, and my desktop fell to fallback mode BUT the screen is bright as hell :D:D Still the button to adjust the brightness doesn’t work. So… It is related to drivers. Are there any other drivers I can try out for intel?

The options are: “intel” driver (default with KMS); “intellegacy” driver (needs edit to /etc/X11/xorg.conf.d/ file); and the inferior “fbdev” driver (from using nomodeset boot option). There is one other, but if you are not sure of your graphics chipset, post the result [using CODE tags] of running the following command in a gnome terminal:

/sbin/lspci -nnk

Include first few/enough lines for details of Memory, VGA, and Display controllers. Ask again if not sure how to. :slight_smile:

I found that this bug is maybe related to Gnome 3
[Test-Announce] GNOME 3 Test Day #1 recap](

First bug on the list. Although, it is for Fedora.

The result of the command: /sbin/lspci -nnk

00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
Subsystem: Samsung Electronics Co Ltd Device [144d:c524]
Kernel driver in use: agpgart-intel
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
Subsystem: Samsung Electronics Co Ltd Device [144d:c524]
Kernel driver in use: i915
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)
Subsystem: Samsung Electronics Co Ltd Device [144d:c524]

I found that this bug is maybe related to Gnome 3
[Test-Announce] GNOME 3 Test Day #1 recap](

First bug on the list. Although, it is for Fedora.

Maybe that bug is related.

You have the same GM45 chipset I have, including the VGA and Display controllers, but my notebook is a ThinkPad (Lenovo). I don’t have problems with LCD brightness with the “intel” driver. However that is with a KDE system and a separate Gnome 2 system (standard).

If you can see enough text, you can enter the command xbacklight in gnome terminal to report current setting (as percentage). You can use the command to change LCD brightness, just type xbacklight --help to list options.

xbacklight shows it’s 100.000000

Also. When I ran the old openSUSE live cd from gnome3 site then the brightness was ok.

That’s 100%, the max. xbacklight adjustment probably won’t help, except to reduce it further. Have you tried it with 11.4 standard Gnome?

No, I actually installed it only beacuse of Gnome 3. I like it very much but ubuntu doesn’t support it at all and Fedora 15 is in alpha stage + it’s installer wanted me to delete my whole drive… I have win 7 there so no go.

But I guess I have to install now Ubuntu 11.04 beta because Gnome 3 doesn’t work for me, atleast now. And I don’t want to go back to old desktops. I like the aero style menu with search bar. I’m a big keyboard user so it’s really fast for me and really pretty. Too bad…