last 11.2 install

No, I don’t mean the last time I will install 11.2 but the last computer I have to upgrade to 11.2. Mostly went well with a couple of major glitches.

I decided to upgrade my workhorse to 11.2 yesterday. I decided on a fresh install to get a new ext4 FS for / rather than convert a ext3 FS. In preparation I made backups of etc opt root srv var in /home/11.1 (/home is a separate XFS partition). Both / and /home are software RAID1.

First glitch was a kernel crash when I booted with the default params. It worked with failsafe so I tried something less drastic, no ACPI and this made it work. I still don’t know why, I have to research why my mobo doesn’t like ACPI. Especially when acpi=off wasn’t needed in 11.1.

Second medium glitch came when partitioning. Naturally I had to reject the automatic suggestion, because it wanted to destroy the RAID. In the manual partitioner I had to use redetect and load previous configuration to get it to see the disks as they were in 11.1. I formatted only / and installed 11.2.

Third major glitch came at the first reboot. GRUB couldn’t find the files. After a bit of poking around, reinstalling grub and rebuilding initrd, I noticed that the root device in menu.lst was wrong. On the disks the first partition is swap, not /. Changing (hd0,0) to (hd0,1) everywhere in menu.lst fixed that.

Once up, I started to bring all the network services back up again, starting with DNS.

Here’s a tip for anybody configuring services on openSUSE. Whenever you install a service, always install the corresponding yast2 module, e.g. yast2-dns-server for bind and use the YaST config for the first run. That way you get to find out which config files are needed. Even if you will eventually manage the config files with a text editor, do use YaST config to create the initial configuration.

This is particularly important in the case of postfix. Several people mentioned they didn’t find /etc/postfix/relay. It was present here. I assume that the YaST config must have created it. Also I prefer to customise postfix via /etc/sysconfig/postfix which controls both and This way I had no problems configuring it to work with gmail’s TLS. There is one patch to the SuSEconfig script needed to handle CApath and CAfile, let me know if you need it, it’s only two lines.

My sound cards were not in the order I wanted and that my recording scripts expected, so I edited modprobe.d/50-sound.conf to fix. It can also be done by deleting and reenabling the sound card entries in YaST, which is probably safer and doesn’t require a restart.

aumix is no longer in the standard repo but in contrib, possibly because it uses the OSS API. I should convert my scripts to use amixer or something like that some day.

I copied the module options I knew were needed for the TV tuner from the old /etc.

I found that the old fmtools wouldn’t work on the tuner. Searching around it seems that recent kernels have removed the v4l1 API. Eventually I found the maintainer of the tools had issued a v4l2 version on Dec 13. See, it pays to wait a while after new-fangled releases come out.

I installed restricted formats via one-click-install and it all worked.

All sorts of favourite packages and software were missing, but this was simply a matter of lots of zypper install commands.

I found that Thunderbird 3 doesn’t support Lightning, but apparently a 1.0 release of Lightning is due any day now. In the meantime I can use a separate Sunbird calendar.

So currently only the LDAP database isn’t restored yet. I’ll have to reload the old LDIF. It isn’t urgent because it’s only used by mail programs as a directory and it isn’t that useful because there is no modify access from user programs anyway.

I would give the experience a 7 out of 10. There were a couple of potential show stoppers if I hadn’t been able to figure them out. But then this machine is quite customised, so it doesn’t represent a typical desktop.

dang ur like a genius. If i ran into any of those type of issues i would of had a temper tatrium because i will spend forever trying to figure it out and get it not working.

but in the end what matters if it works, right? :wink:

I think this one would have given me major heartburn. This is the first I’ve read of the menu.lst trying to mount the swap as if it is the / ! I wonder what confused the openSUSE installer software …

I’m only just getting a handle on multiple sound cards. Around a month ago I noted to my wife I wanted a second sound card so I could learn more about what was involved in configuring multiple sound cards, and that it would make a good Christmas present! :slight_smile:

She looked at me like I was from Mars, and then she went rummaging through our storage area (that has many old computer parts - when ever a friend’s PC dies, we ask that they give us their dead PC’s parts) and she pulled out an ancient Ensoniq sound blaster 128 PCI card (which is more than 10 years old) and told me “Merry Christmas” ! … < arrrggggg > … :frowning:

But I did plug that in my sandbox PC, it does work, and I’m now learning a bit about running openSUSE with multiple sound cards.

I documented my experiences in this thread, starting on post #14 M-Audio Audiophile 2496 No Sound - openSUSE Forums

Thanks for sharing your experiences. Most interesting! IMHO it illustrates some interesting tidbits, especially how a user experienced with the finicky aspects of openSUSE can succeed, where others may have blocking problems.

The problems with RAID on install have been reported many times. Perl_BootLoader has a fix for that in update/11.2-test. You might want to try out the kernel update to, and see if that helps the ACPI problems. There were not many kernel bug reports at release time, so such regressions should have decent chance of getting fixed.

How updates are going to help ppl steered to installing with 11.2-GM is unclear to me.

My only concern about not having ACPI is that it might not permit the power consumption to be lowered when less active. But the computer doesn’t seem to run any warmer than before so I suppose the lack of ACPI hasn’t changed anything. I think the OS is able to throttle the CPU speed. Since it’s a tower, I’m not worried about running down batteries or anything like that. I suspect that the mobo is somewhat non-compliant wrt Linux and it didn’t have ACPI on 11.1 either but the kernel automatically coped before.

There was also something about no IOMMU but there is no BIOS setting for it so I can’t do anything about that. I think I shall leave well enough alone.