Laptop only reboots after OpenSUSE 11

I’ve been running OpenSUSE10.3 flawless on my laptop
(Acer TM4000 w/ATI Mobility Radeon 9700 64MB)

So now i wanted to try v.11

Installation run trough without any problems and when it was finished and try to startup GUI, then i automatic reboot.
I try to boot in failsafe mode, but it still reboot. I reinstalled it and choose not automatic configuration and everything run ok during install. At the end with hardware configuration, it find the gfx-card identified as ATI R350 and set the right resolution. There is no way to test gfx-settings like in 10.3

Nothing wrong happens! No errormessages!
It finished and when its about to start GUI, then it reboots.

Im very sure it is the driver for ATI that cause the reboot because if a look at the cli boot-screen it doesnt show any errors.

So how do i fix this?

Maybe try booting to run level 3 and see if it will run with a vesa driver?

So turn on the laptop, and when you see the grub menu (thats the menu where you choose windoze, or openSUSE-11.0, or openSUSE-11.0 fail safe) type in “3” (no quotes). It should boot to an ascii prompt. Login as a regular user (and enter regular user password). Then type ‘su’ (and enter root password when prompted).

Then type (for my curiousity, not part of the recovery):
grep -i driver /etc/X11/xorg.conf
record and post here the output.

Then type
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.newbackup
to make a backup copy of your xorg (probably not necessary).

Then type
sax2 -p
and it should list your graphic device as “chip:0”.

Then try different graphic drivers with the sax2 command until one works (you will know it seems to work if you get no errors). ie:
sax2 -r -m 0=vesa (that is zero equals vesa)
sax2 -r -m 0=ati
sax2 -r -m 0=radeon
sax2 -r -m 0=fglrx
sax2 -a
sax2 -l

as soon as you get one of the above not to spout out errors, then exit sax2, and type ‘exit’ to get rid of root permissions. If necessary type ‘exit’ twice.

Then type “startx” (no quotes) to start X.

Does that work?

No it want boot into CLI
When i boot into grub, there is a line that says something like “vga=0x307”. (Well i dont remember exactly the number) If a delete everything and only put “3” there, then it boot with big textsize, but it still reboot.
Can i change the line to “vga=vesa”?

It seems like it still reboot in whatever i do!

Now some funny updates:
I get tired and reinstalled everything again. I run trough “Check media” to see if there was some MD5-errors on media, but it seems fine.
After reinstalling i get it connectet til internett og did an upgrade during installation/configuration. Now it booted up and it works. Then i did the misstake to enable 3D accelaration and rebooted. Now its back to rebooting aganin :frowning:

It seems 3D is the problem, but why want it boot into CLI?


Your post makes me think mine must have been very unclear to you.

PLEASE, the intent of my post was for you to boot into CLI (ie from a terminal/run-level3) !!! Do NOT type those commands in Grub. Only type “3” in grub, and NOT as a replacement, but on the end of what every other option you are applying to boot.

Once in CLI/Run-Level-3, then apply the various sax2 commands from the CLI.


Likely because your graphics config is not setup for your hardware, and possibly because no matter what you will need a custom graphic driver.

I know what you ment :slight_smile:

I tried to just tapp 3 and then Enter! But again it rebooted. Now im frighten! I did again a reinstall and did exactly the same as what i did last time. But now my NIC’s didnt startup and i could’t connect to internet.
Last time the wlan-nic connect with no problem. I also tried LAN-nic.
Computer have Intel PRO 2200BG wlan and Broadcom 4400. Very standard hardware with no problems earlier. Can it be possible one of my nic got a bad driver from OS11?

Is it possible to boot without nic?


I assume you tried to start with fail safe setting?

Am I correct that the symptoms are not random, but rather they are deteriorating? If so (and if they are deteriorating), then I think you should check your hardware. Do you have another OS in a different boot partition you can boot to, in order to confirm this is not hardware?

No i dont have another OS-boot, but i have installed 10.3 and its working perfect.
So there must be something wrong with OS11.
Im in fact now suspecting drivers for eigther Broadcom 4401 LAN or Intel Pro 2200BG wlan.
I register that i couldnt connect to internet during installation over LAN. I did once get 2200BG to work and that time i manage to get OS11 up and running. If i tried Broadcom LAN it want receive any IP from dhcp.
In 10.3 this is no problem.

So can someone check out the “b44” driver for Broadcom. I guess the driver in OS11 is corrupt/bad.