Laptop going to sleep


I have a relatively fresh openSUSE install. My problem is that every time I unplug the power, after a short time(5 min tops) the system says that it is low on battery and will go to sleep(even though I’m 100% the battery is full). If I need to post any additional info please tell me how. If is setting related then please tell me where and how to fix it. Thank you.

You need to look at the power settings.
I think if you go into Yast and double click “power option” you should find the settings.

Yast in my install of openSUSE 11.1 doesn’t seem to have a “Power Management” icon.

My laptop goes to sleep so fast that it won’t boot unless I jiggle the mouse or hit enter every few seconds.

It should be under Yast - System - Power Management. If not, start the software installer and install the package yas2-power-management. After that you will have an icon.

Please also check which profile is selected in KDE’s power management. Check configuration of active profile.