Laptop cam is not working anymore

lsusb -vHi guys,

“Cheese” is showing me this message: “No devices found”.

I already tried to reinstall it and also some packages, but nothing work.

Some useful information:

viniciusbr@linux-9urx:~> cheeseGtk-Message: Failed to load module "unity-gtk-module"Gtk-Message: Failed to load module "unity-gtk-module"
(cheese:30038): Gtk-WARNING **: Theme parsing error: cheese.css:7:35: The style property GtkScrollbar:min-slider-length is deprecated and shouldn't be used anymore. It will be removed in a future version** Message: cheese-application.vala:211: Error during camera setup: Nenhum dispositivo localizado

(cheese:30038): cheese-CRITICAL **: cheese_camera_device_get_name: assertion 'CHEESE_IS_CAMERA_DEVICE (device)' failed
(cheese:30038): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed
(cheese:30038): GLib-GIO-CRITICAL **: g_settings_schema_key_type_check: assertion 'value != NULL' failed
(cheese:30038): GLib-CRITICAL **: g_variant_get_type_string: assertion 'value != NULL' failed
(cheese:30038): GLib-GIO-CRITICAL **: g_settings_set_value: key 'camera' in 'org.gnome.Cheese' expects type 's', but a GVariant of type '(null)' was given
** (cheese:30038): CRITICAL **: cheese_preferences_dialog_setup_resolutions_for_device: assertion 'device != NULL' failed

And the **lsusb -v **is here: and sudo lspci -k here

The webcam device is reported in the lsusb output

Bus 001 Device 004: ID 13d3:5165 IMC Networks

Let’s see if a driver is loaded…

usb-devices|awk '/13d3/' RS="


and a device node exists…

ls -l /dev/video*

It does look like your problem is with the application/supporting libraries though. Where did you install that application from?

I recall an old thread on this make of webcam: where my old research suggested the webcam is UVC compatible.

I’m not up to date wrt support apps needed, but back in the openSUSE-13.1 days various v4l libraries were needed for webcam functionality.

I also read a post where this error message:

g_settings_set_value: key 'camera' in 'org.gnome.Cheese' expects type 's', but a GVariant of type '(null)' was given

was because a user had the webcam switched off in BIOS. That may not be the cause here, but its likely worth checking.

Yes, agreed…and perhaps making sure that firmware is loaded (if applicable).

viniciusbr@linux-9urx:~> usb-devices|awk '/13d3/' RS="

"T:  Bus=01 Lev=02 Prnt=02 Port=02 Cnt=02 Dev#=  4 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=ef(misc ) Sub=02 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=13d3 ProdID=5165 Rev=08.23
S:  Manufacturer=Azurewave
S:  Product=USB Camera
S:  SerialNumber=NULL
C:  #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=0e(video) Sub=01 Prot=00 Driver=uvcvideo
I:  If#= 1 Alt= 0 #EPs= 0 Cls=0e(video) Sub=02 Prot=00 Driver=uvcvideo

viniciusbr@linux-9urx:~> ls -l /dev/video*
crw-rw----+ 1 root video 81, 0 Set 15 10:00 /dev/video0

I looked in the bios but something seems to be OK (despite I don’t know exactly were can I find information about the cam).

Direct from the official repos.

I have read of users with the 13d3:5165 webcam complaining they could not get it to work under GNU/Linux. I’ve also read of others succeeding if they also use v4l apps to assist. Have you tried investigating if v4l apps may help ? I can’t provide any more specific advice, as my laptop will run cheese without v4l - but then it is a different make of webcam.

Hi, thanks!

I tried to install OBS but also didn’t work. So I tried guvcview and the webcam worked!

This is strange, once guvcview works and cheese don’t.

I note the device permissions are set as root:video, which means that the user needs to be in the video group to access this device. Check that is the case.

I didn’t see this post before my previous reply. If guvcview works then maybe the user is already a member of the video group. Anyway, at least it’s just an application-related issue.

Thank you!

I also had problems with my laptop’s webcam and I was able to solve it.

I went to a technical service and was told that the integrated cam on my laptop was having problems with the manufacturer. They changed for just $ 25 my webcam](