Laptop boots into shell

Today I installed opensuse tumbleweed on my iball compbook i360. I am unable to boot in OS and instead It opens in shell

Boot your install media to the rescue system, where you can login as root.

Run the command

efibootmgr -v

and post the results here.

You might find it useful to mount a Windows partition or a USB drive, and redirect the output of that command to a file on the mounted drive. That’s easier than making a pencil and paper copy.

Above command returns this

Is secureboot and fastboot and similar options disabled in the BIOS/UEFI menu?

If not please try and disable it.

One more question: Is your openSUSE installation selectable for boot in the UEFI/BIOS?

I’m not sure, but it looks as if this is an HP computer. I don’t have experience with those. It is my understanding that they initially only allow Windows or maybe RedHat linux. There’s a BIOS option that needs to be set for them to be able to boot other systems.

Some other possibilities to try:

Boot your install medium. There should be an option to boot hard drive. Check whether that gets into your system.

If that fails, then the boot menu for the installer should also have an “other” option. Select that, and there should be a choice to boot the installed system.

If you are able to suitably change the BIOS settings, then the easiest way to fix your problem will be to use Yast bootloader to reinstall booting. Just change something (change the timeout by 1 second), and it will do a reinstall. Of course you need to get into your system to be able to run Yast bootloader.

@nrickert Never seen that on all my HP’s (Currently have 3 HP Laptops and a Workstation) UEFI boot…

@Rajsonkar what @nrickert says about booting from install media, or power on and press F9 to get to the boot menu…

No. But there are older reports of the same issue. According to this discussion, these systems have 32 bit firmware. Which means it is not possible to install out of the box. The output of

cat /sys/firmware/efi/fw_platform_size

would be interesting.

No. It is not selectable. It does not show up in boot order.

That would explain the issue. Install works with recent Tumbleweed, but it won’t install booting properly, partly because the install medium does not include the needed “grub2-i386-efi” package.

If that is the problem, then booting is still possible, but it requires some extra effort. I have that setup working here in a VM.

It should be possible to boot using the “Boot linux system” option from the install media. It is easier to fix his problem after booting that way than by using the rescue system.

According to that:
https://www.iball.co.in/Product/CompBook/i360-FHD/11324

it has an Intel® Atom™ Processor x5-Z8350, up to 1.92 GHz, which should have a 64 bit architecture.

I had a the problem of my install not showing up for boot on my Acer ES-132 netbook. The reason was that someone at the UEFI manufacturer thought it was a good idea to apply fixed paths for the .efi-file.

My solution was to copy the default .efi-file that’s created by openSUSE from /boot/efi/EFI/opensuse/grubx64.efi to /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi

(Note: That’s just valid if you use the default esp-path.)

This is the default path for the Microsoft Windows Bootloader. You should be able to do that by using a live image of any Linux distribution as long as you can access your /boot/efi partition (or root partition if you don’t have a seperate EFi system partition).

After successfully copying the file please check if Windows Boot Manager is available in the UEFI boot menu. If so, boot it up and you should end up booting your openSUSE install.

If that works, please report back here. I also found a solution to automize the process of copying that .efi file whenever it’s altered. If you don’t do that it’s just a matter of time until you have the same issue.

Oh and of course the very first thing I would do is checking the hash sum of your install image, in case you didn’t do that yet…

Many systems with Intel Atom processors used 32-bit EFI firmware even though the processor supported 64-bit.

If it happens to use 32-bit firmware, then it will ignore any “grubx64.efi” file as incompatible.

My VM with 32-bit firmware uses “grubia32.efi”. But you cannot just rename the file, for the content would still be wrong.

1 Like

It is a Xiaomi Mi system.

According to some tech news from 2017 you are right and it indeed ships with 32bit Windows by default.

So, another thing to check for @Rajsonkar
There is a Tumbleweed version for 32 bit available for Download it seems.

He is better off with the 64-bit version of Tumbleweed. It just needs a little adjustment to allow for 3-bit efi.