Language setting

When I installed Leap 15 I set the language as English UK. Now every time I open an application the language is English US. I have to reset this every time I open the computer, using KDE System Settings. The language shown in the System tray is still English US. Where can I change this setting?

Who is the “I” here?

You, as system manager, have installed the system and set it’s system language to English US. That means e.g. that user root will get output of programs/tools in English US.

When you as another user (or any other “other user”) uses KDE and sets language there, that should stick for that user also in his/her forthcoming KDE session.

Now please explain if the above is, or is not, to your experience. And please use the username you use, Saying “I” for everything you do, regardless of user (root or other) does not help others to understand what you do. A Linux system does not know any “I”, or “you”, it only knows about usernames.

I, as system manager I presume, installed the software initially setting the language during installation as English UK and the keyboard layout to be English UK.

I, as user Mike, login each time I use the computer and the language appears as English US. To get the English UK settings I wish to use I go to KDE system settings and change the language to English UK in Input devices, keyboard, Layout. In the System tray the symbol EN appears and the language is English US.

Thanks, that is very clear to me now. Changing from English US to English UK does not stick over sessions in KDE.

I used the KDE system settings > Regional Settings > Language (and others there). Is this different from where you tried to do it? KDE has so many settings and it is often not obvious where to find what one needs :frowning:

Good morning Henk, apologies for seeming to ignore this query, I have been recovering from CoVid since 12/07 and only just able to reply.

I have checked KDE system/Regional settings/Language and the only setting is ‘British English’. The system tray EN symbol shows ‘English US’

Could you think of anywhere else this setting may be located? Thanks for any help.

About that system tray EN, I do not have it on the system I am working on now, but have have seen it on my wife’s system and another one. When I click on it it says English - English(US). When I right click and then choose About it opens a window with says IBus. I do not know what it is, even if it is something KDE. I also do not know whay it isn’t on all systems.

I think I remember that removing it (via right-cliclk) did not do much, but it returned (after new login?)

Well, you see, I am not the best one for this IBus thing, but it may have to do with your problem.

It does not appear to have anything to do with my locale. That is Dutch (nl_NL).

When the I of IBus means Input, then it will not influence your locale/LANGUAGE.

Thanks Henk. I have the same experience with the EN symbol in the System Tray. If I delete it, it just comes back. I’ll try some searching around IBus, see if I get anywhere.

Cheers, Mike

Googled ‘KDE System tray IBus’, got lots of links. Best one seemed to be as follows:

IBus - right click on System Tray, select Preferences/Input Method. Mine showed ‘English US’. Click Add and select language - the only UK offered was ‘English(UK - extended WinKeys)’. Removed ‘English (US)’. Seemed to be working OK. To confirm I rebooted and it still comes up as ‘English UK - extended WinKeys’ Keyboard now types UK symbols.

I am not sure I get it.

You now changed something on the input side, has influence on keyboard usage. And you seem to be glad with it.

But the question was (as I interpreted it) that you had a problem with LANGUAGE, with is on the output side. The LANGUAGE environment variable is used by many programs to output messages in that language (if available).
In your case, that would in a theoretical program that outputs a theoretical message like
“This is a bad color definition” in English (US)
“This is a bad colour definition” in English (UK)

Having made this change, the keyboard input to all text is English UK. This is particularly noticeable for symbols eg
In UK, the shift+2 key gives ", US gives @
In UK, the shift+’ key gives @, US gives "
This was a problem typing documents, and email addresses, which is now solved.

Not sure I really understand your example, although I’m sure you are correct.
I dislike IBus, and I delete it, and mark it with taboo.

I think I found out while I have it on some systems and not on others. It is installed as a dependency of zoom.

Thus if I want to remove it, YaST warns me that either zoom should be removed also, or that zoom will be broken.

I am not sure if a such broken zoom will still function to satisfaction.