Lamp, work directory


I installed Lamp and everythings goes fine except the fact that I don’t know how to set up the working directory of my project.
The lamp directory is on /srv/www/htdocs while my project is in /home/user/Web. If I set the working directory in default-server.conf I can’t use anymore phpmyadmin from the browser. I tryed to configure a Virtual Host but I think It was no good.

I made it work.

Just a note to say that the link in Lamp User Guide at the end of it doesn’t work.

The procedure is the follow:

Go inside /etc/apache2/vhosts.d
Create a copy of “vhost.template” and rename it “mysite.conf” (this file will be automatically loaded from apache)
Change DocumentRoot in /path/to/my/site/files
Make the same for Directory -> /path/to/my/site/files
Eventually is possible to set a particular domain but I didn’t need any.

Chapter Apache

As I didn’t do nothing. It gives only the first window of phpmyadmin and after it doesn’t find it.

If I write the directive

Alias /webname /path/to/webname/

And I try to access It gives me that is not allowed to get In?

Anyone knows?

I tried to write

<Directory “/path/o/webname”>
Order allow,deny
Allow from all

but doesn’t work.

Have a look in /etc/phpMyAdmin, there’s a file, you should be able to set the necessary variables in it.

if I use phpmyadmin in default configuration it works fine. his setting a different folder for project that make miss the phpmyadmin configuration.


add Alias as in the example of the file with correct “/”

It works

Nice, could you produce a more detailed explanation? Would be nice for others that face the same issue