kwin_x11 high up cpu usage and plasma problems

Hello friends.
There are many using slackware with KDE, I decided to use openSUSE Leap 15 with plasma for ease of management.
But I am facing some problems, since I use all day to work.
1 - kwin_x11 is always on top of CPU usage and memory, how to solve it?

2 - After boot, when loading the graphical environment in the LEAP logo takes more than 5 minutes to enter the Desktop.
3 - During use, when a notification appears in the bar, the machine freezes for a few seconds or minutes.
4 - In this same symptom, when returning the mouse does not click, but moves and changes the type normally, only the click does not work.

Thank you in advance for your attention.

Are you using the same home configuration files as you had on slack?? Could be different versions and options between OS causing problem. Try a new test user

Actually I made a copy between ‘home’ and believe that the configuration files gave problem.
I created a new user and am using it and so far there have been no latches and kwin consumption has decreased.
I will continue to follow up during the day and see if it really solved it.
Thank you gogalthorp

After six hours working with the new user, opening the SoapUI machine slowed down.
I had to reboot.
Would it have something to do with java?

Check memory usage maybe you pushed things to swap.

Thanks for the feedback.
To add more information, my OpenSUSE is in a virtual machine on a Windows 10 notebook with 6GB of RAM.
I leave 3GB of RAM allocated to it.
This links are a ‘top’ and a ‘free-m’ at the time I run something based on java.




Looks like you push the memory to the limit

Swap usage can cause high CPU usage and slow downs

How can I improve this?
Do you have any tips?

Don’t us so much memory or add more. Maybe a lighter desktop???

I’ll do some testing. Thank you very much.

According to the free -m output the OP linked, swap usage is less than 10%, so this shouldn’t be the main problem, I think.

I’m curious about the high memory usage shown. I thought perhaps it was due to the cache technique that linux uses, where low free memory doesn’t necessarily means too little memory, due to said cache.

My version of free reports:

:~> free -V
free from procps-ng 3.3.9

:~> free -m
             total       used       free     shared    buffers     cached
Mem:         24050      23765        285         87        137      15676
-/+ buffers/cache:       7951      16099
Swap:         4098          0       4098

The OP listing doesn’t show the +/- buffers/cache line, and has the “available field”. It does seem like a RAM issue, however.

Some issues that I remember were posted in the forum is that animated widgets make x11 hog the CPU, more in weaker processors. Clocks with seconds, progress widgets, etc. Perhaps this is contributing as well. Also desktop effects (composite), although I doubt the OP would be using these in a VM.

Any swap usage may degrade performance if a process starts using it. You don’t have to saturate swap to see system degradation

I upgraded memory to 4GB and am able to use java-based programs without crashing so far.
I also updated the version of VirtualBox.
I’m following up.

Thanks gogalthorp and brunomcl