kwin effects not enabled at login

I’m having 2 small problems with kwin effects.

My first problem is, that the effects aren’t enabled when I log in. The weird thing is, that I can enable them by pressing Alt+F12 but I have to press it twice. So I think that the system thinks that the effects are enabled, but for some reason isn’t rendering the desktop correctly.

My second problem is, that I can’t seem to get cover switch to work. It’s checked in my kwin effects settings, but I keep getting the tabbox.

My graphics card is an ati hd3650 with the latest fglrx drivers from the ati repositories installed.

Below are the compositing settings from the kwinrc file if that helps finding the problem


Thanks for the help.

A good troubleshooting method is to create a new user account and see if the behaviour is the same there. Sometimes .kde4 gets cruddy and may need to be replaced with a new .kde4 folder. But before we do that, try a new account and see if it is the same.
Login as the new user, try it and report back.

Created a new account and also have the same problems in that account. Won’t start compositing effects unless I press Alt+F12 twice. Cover switch still showing tabbox.

You have checked the box in system settings to enable desktop effects?](

Effects have been enabled, but under compositing state is says that compositing has been temporarily disabled.

I expect this is an issue with your graphics drivers.
Unfortunately. ATI is not my field. @oldcpu may be able to help you if he sees this.
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums