kwin crashes

Hello everyone !:slight_smile:

i am new to linux plateform and installed 11.2 under KDE an hour ago.

when the system booted for the first time , the resolution was not optimum. my monitor is samsung 2033 (1600x900) and gfx card (ATI HD 4850).

i downloaded the ATI 9.10 driver for linux and installed according to the instructions given in the pdf.
and when i rebooted the pc again , i see a message saying that kwin is unstable and is crashed !:’(

moreover , its not showing the title bar on the windows that i open :frowning:

so plz help me solve this problem and i request you to give the solution step by step as i m a noob !

Note :- i had installed 11.1 earlier for 10-15 days but i did not have gfx card that time ! Bought a new pc :wink:

Your problem would be the Radeon card.

New Catalyst drivers were released just a few days ago, give those a spin and report back?

hey ! ok , i will try the new drivers !

But ,for trying the new drivers i would have to uninstall the prev ones(9.10) ,how do i do that ?:expressionless:

plz keep in mind that my gui isnt working so all i m left with is cli !

There is a URL with guidance here:
ATI/The Hard Way - openSUSE

When installing the previous 9.10, assuming you installed “the hardway”, then in one of the steps you installed the driver package with " rpm -Uvh fgl*.rpm ".

So now you need to remove that package. You can do so by typing with root permissions:

rpm -e $(rpm -qa '*fglrx*')

The instruction is in the ATI/The Hard Way - openSUSE link, but I concede it is a pain to read all that and figure out just what applies and what does not apply.

******Rawr! Edited :slight_smile:
**

i installed the driver using this instructions :-

  1. Launch the Terminal Application/Window and navigate to the ATI Proprietary Linux
    driver download.

  2. Enter the command sh ./ati-driver-installer-9-10-x86.x86_64.run to launch the ATI
    Proprietary Linux driver installer.

after installing it i did ,

  1. Launch the Terminal Application/Window and run:
    For versions of X.Org newer than 7, /usr/bin/aticonfig --initial to configure the
    driver for your ATI product.

and for uninstalling :-

  1. Launch the Terminal Application/Window and navigate to the /usr/share/ati folder.

  2. With superuser permissions, enter the command “sh ./fglrx-uninstall.sh”.

  3. Reboot

now , To restore the original Xorg configuration file:-

  1. Locate backup configuration files: ls /etc/X11/xorg.conf.original-*
  2. Take the latest version with the highest number and copy it over the existing
    xorg.conf file: cp /etc/X11/xorg.conf.original-<number> /etc/X11/xorg.conf

in my case the number was ‘0’ and finally when i rebooted the system it failed to load the gui !

now should i continue with the hard way guide in the present state or is there something that i should do before continuing ?:expressionless:

dk0505, sorry to read of your difficulties on your first openSUSE attempt.

The proprietary ATI driver is not very mature when it comes to openSUSE-11.2 (it works well with 11.1) and unfortunately there have also been reports of the open source ATI driver having some problems with 3D/special desktop effects with some users on 11.2.

When I read your post, one thing that puzzles me very much is you make no mention of installing the proprietary driver package with " rpm -Uvh fgl*.rpm " (where you need to substitute the exact name of the rpm) where that rpm is built by running the ATI proprietary " .run" file . When the ATI "ati-driver-installer-9-10-x86.x86_64.run " is launched, my recollection is it will create an "fgl.rpm" file. That file must then be installed for the driver to be installed. And ONLY after that rpm file is installed, should one run " aticonfig --initial " …

It does appear to me that you missed a step.

Now I have no idea as to what the effect is of running " aticonfig --initial " without first installing the rpm. I hope it is harmless, but I don’t know.

I’m not sure this post is helpful, but I hope it is. Please advise as to what you did wrt the fgl*.rpm ?

Enter the command sh ./ati-driver-installer-9-10-x86.x86_64.run to launch the ATI
Proprietary Linux driver installer.

when i entered this , it launched the driver setup as it says.

i have no idea about the rpm file which u mentioned.

and when i ran ‘–initial’ it said that ‘the back-up is saved to smthng-smthng location’ :expressionless:

but if u say that i may have missed a step , then there may be a possibility that i have !

Now tell me step by step…what to do and i will post the result.

Note - i just have the cli option to do anything !

dk0505, when I look here:
ATI/The Hard Way - openSUSE

I note in step #3



Login and go to the directory containing the drivers package we just made.

 # cd /directory_where_you_generated_the_rpm

Install the driver package

 # rpm -Uvh fgl*.rpm

After the install is finished, you need to launch the aticonfig utility

   # ldconfig
   # aticonfig --initial --input=/etc/X11/xorg.conf
..............

But the instructions which I followed didnt involve the rpm thing.

Now in the hard-way guide :-

sh ati-driver-installer-8.7-x86.x86_64.run --listpkg

I didnt give the listpkg parameter and it directly launched the ATI installer.

Anyways…now that i have uninstalled the drivers , should I install the 9.11 proprietary drivers referring to the hard-way guide ?

Can you point to those instructions?

I’m no ATI expert. We have 2 PCs in our place that use ATI hardware

  • my wife’s PC (running openSUSE-11.2), which has an ATI RV280 (equivalent to a Radeon 9200 Pro), on which I only have used the “radeon” open source driver, and
  • our Dell Studio 1537 laptop (running openSUSE-11.1) which has an ATI Radeon 3450 HD graphics, on which I currently use the proprietary ATI graphic driver, that I used installing “the hardway” per the link I provided

I had “assumed” one had to follow all steps in “the hardway” method. If it is possible to skip those steps without any risk, then that is new to me, BUT as noted, I am no ATI expert.

Can you point to those instructions?

yup , sure , here is the link :-

ATI Catalyst™ Proprietary Display Driver

Please see the installer instructions. These are the instructions that I followed (the driver ver was 9.10 obviously) for installing and then uninstalling(when it didnt work !) :slight_smile:

Those instructions bring up a GUI, where possibly as part of the GUI the rpm is installed? I do not know, as I have never followed that method.

The “hardway” method specifies command line options with the command … ie assuming kernel-source, kernel-syms, linux-kernel-header, and the baseline development pattern are installed, and assuming one is in run level 3 with root permissions, and assuming one’s terminal is in the directory where the .run installer is located, one types something like (for a 64-bit openSUSE-11.2):

mv /etc/X11/xorg/conf /etc/X11/xorg.conf.mybackup 
 rpm -e $(rpm -qa '*fglrx*') 
sh ati*.run --listpkg
 sh ati*.run --buildpkg SuSE/SUSE112-AMD64 
rpm -Uvh fgl*.rpm
ldconfig 
aticonfig --initial 

and then restarts.

Those commands need to be modified as appropriate to fit in with the specifics of one’s situation. … and again, I am no expert.

okay , so now I am gonna install the 9.11 drivers referring to the hardway.

This is what I am gonna do (Mentioning only the headings as mentioned in the hardway) :-

Installation - Get and Install ATI Drivers

I have to follow the yast method as I dont have the gui option.

and finally :-

Configuring the newly installed ATI driver

Is it alright ?

I do not know what you mean by the “yast method”.

this thread should be applicable to the discussion here, because it will illuminate the difficulty that everyone is having, kudos to NicoK for taking the time to research it.

Generating catalyst 9.11 rpm’s on openSUSE 11.2 - openSUSE Forums

Seems to be a syntax change in the version of rpm that 11.2 ships with, and ATI simply missed it. Rpm v4.7.1 also drops the --repackage option which i miss.

a machine that has a 3850HD card runs better than ever before with the new drivers, so i hope this fix gets to be available for the masses.

my 2 cents. :slight_smile:

From yast method I meant :-

===Installation - Get and Install ATI Drivers===

At this point, you can use the YUM repository at www2.ati.com like this:

YaST -> Software -> Change installation Source -> Add

Protocol: http
Server Name: : www2.ati.com
Directory on Server: suse/10.2

to add the ATI http server as additional installation source.
Now use

YaST -> Software -> Install and Delete Software

to install the ATI/fglrx driver. Select the following packages:

x11-video-fglrxG01
ati-fglrxG01-kmp-<kernel-flavor>

<kernel-flavor> depends on your installed kernel. Check with
“uname -r” for installed default/smp/bigsmp kernel. Use “sax2 -r”
for X.Org configuration.‘’

And as per the guide , if I do the above i dont have to do manual driver package generation and installation right ?

Err…please dont mind the silly questions…I already mentioned that i m a new user !:shame:

Maan , will someone please tell me…how will I follow the instructions given by Nicok in cli(like downloading the ati drivers and all) ? :expressionless:

How many times I will have to mention that I am a new user and I dont know anything about zypper or rpm or copying or moving a file via cli !:expressionless:

No, I do not recommend installing the ATI driver via yast at this time. That is because last I had heard they had not yet been built for 11.2.

Typically, for the proprietary ATI driver, there are two methods of installing the driver (in fact there is likely more, but for our purposes we will ONLY talk about these two). These two methods are to either:

  • (a) Install a software repository (where the repository contains the ATI driver) to the YaST/zypper repository list, and then install a pre-compiled rpm of the ATI driver, or
  • (b) custom build the ATI driver (which is called “the hardway” ) by running the binary .run file. When that file is run, it creates an rpm with “fglrx” in the file name, where the “fglrx” rpm is then installed before the aticonfig program is run. I outlined this “hardway” method above.

I do not recommend method (a) at this time, because last I had checked, the latest ATI driver was not yet built as a pre-compiled rpm for openSUSE.

Now to custom build a driver (which is the “hardway method” (b) above) , one needs to 1st go to YaST > Software > Software Management and change the “filter” to “pattern” and install the Base Development pattern. That is a big download and will take a while. Once that is complete, one then needs to change the “filter” to “search” and search for and install kernel-source, kernel-syms, and linux-kernel-headers.

Then once those are done, one can proceed with the hardway installation that is outlined above, and also outlined where the text in ATI/The Hard Way - openSUSE starts reading like …


OR

You can continue with the following instructions for manual driver package generation and installation...

**Step 1 - Acquire the latest ATI driver**

Go to ATI's website and download the installer -- Latest as of December 21st, 2008 -- Catalyst 8.12.

NOTE: Latest and all previous drivers for 32-bit Linux may be found at this ATI website page, and for 64-bit at this page.

**Step 2 - Generate Distribution Specific Driver Package**

You may want to use Sax2 to create default xorg.conf by executing the command: 
..................
.................
.............. etc ..............

In my case I always skip the “sax2 -a” step, as I do not believe it adds anything.

my apologies for making a confusing issue even more difficult, trying to make a rpm the hard way will surely fail unless Nicok patch or the manual equivalent is done.

oldcpu is, as usual, correct in advising that the radeonhd driver is a good way to get you up and running without much difficulty.

good luck :slight_smile: