Kwallet -

In my the Akonadi Personal Information Management framework I’m trying to configure the Google resources, but I get an error saying that it can’t access kwallet. I discovered that kwallet isn’t running, so I try to start it but am told that the system security policy is preventing it (see attached screenshot.) I’m not familiar with the workings of this security system, and don’t know where or how to even look to find the fix. Can someone help me fix this?

It’s hard to know how to fix it, when I don’t know what’s broken.

Here are two possibilities that might have caused the problem:

(1) at some time, you ran your desktop session as root, and some of the files are now owned by root so that you cannot change them.

(2) you were prompted for a password before changing wallet settings, and you gave the wrong password (it is asking for your own login password, not for the root password).

That’s the problem. I have no idea what’s broken. If I did I probably could have fixed it by now.

I tried forcing a reinstall of kwallet - no joy.

This might be a clue: I tried to run kwalletmanager from the command line as a user and got this:

russ@behne:~> kwalletmanager
unnamed app(32678): KUniqueApplication: Cannot find the D-Bus session server:  "Unable to autolaunch a dbus-daemon without a $DISPLAY for X11" 

unnamed app(32677): KUniqueApplication: Pipe closed unexpectedly. 

The same command when run as root results in this:

behne:/etc # kwalletmanager
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
QDBusConnection: name 'org.kde.kwalletd' had owner '' but we thought it was ':1.38'

It’s all Greek to me. Perhaps someone can make something of this.

Apparently there’s something wrong with your polkit setup, or your user session is not correctly registered with logind.

Try putting this into /etc/polkit-default-privs.local and run “sudo set_polkit_default_privs”, to see if it helps: yes

Ok, I did that. but no joy. When trying to start kwallet I still get this:

Sorry, the system security policy didn't allow you to save the changes.

Did you run “sudo set_polkit_default_privs” after making the change?

Does it work on a fresh user account?

Does “loginctl” show your user session?

Is “polkit-kde-authentication-agent-1” running?