KVM - VM install of leap 42 install hangs at system probe

New install of leap 42. Installed Kvm and it completed successfully. Created new VM and started install of leap 42 for test machine. The install progressed just fine until the probing system screen. At this point the install hangs and never continues. Have to force off the VM. Not sure why I this this is happening or how to resolve.

Any suggestions would be appreciated.

Did you run a system update on your Host immediately after installing virtualization?

zypper up

Then, the question is whether you’re pointing to an ISO (highly recommended) or a physical DVDROM or something else as your install source.


I did run an update after the install. I was using a dvd and not an iso image. i will give the iso a try next.

The idea behind pointing to an iso is to use hard drive I/O speed, either you may not be waiting long enough or reading from the physical DVD may just hang for unknown reasons.


i get your point on waiting, but i thinking being hung for 15+ hours is a different story. i am starting the build from an iso now.

Well i tried it again an still no luck. so i started to to look around and then went in to create another virtual machine and i noticed the following message pop up: "Warning KVM is not available. This may mean the KVM package is not installed or the KVM kernel modules are not loaded. your virtual machines may perform poorly.

I went into software manger and kvm is installed it appears. i also checked qemu and many packages installed as well. So i am guessing i am missing something which is not obvious.

Just a bit more detail. the method i used to install kvm was as follows: “yast” -> “virtualization” -> “install Hypervisor and tools”. From their the install continued. checked for updates. I assumed that this was the complete install, which that may have been my mistake to assume. Is there another step i maybe missing.

You can try re-installing libvirt which includes the vm creation tool

zypper in -f libvirt

You can also try installing the Guest as I describe below. I always do accept one default and I recommend to others as well.

Since this is a brand new machine and LEAP installs so quickly (typically <20 minutes for me), I’d also consider wiping everything clean and starting from scratch again.

  • Install LEAP for your HostOS.
  • Update your system, it’s often critically important you do this before installing virtualization
zypper up
  • Reboot
  • Install virtualization using YAST. Accept all default suggestions unless you <really> know what you’re doing.
  • Although likely not necessary, I typically run “zypper up” again just to make sure everything is sync-d up properly.
  • Now, try creating a Guest. For all virtualization technologies I do <not> accept the default to install the OS immediately, it can lead to undesirable defaults. Instead I select the option “Don’t install OS at this time” or similar, then at the very last step when the Guest Install options are displayed for review, <then> I set the virtual CDROM to point to the ISO. Because all virtualization will boot to the CDROM if the virtual hard disk is unbootable, the install will proceed automatically when you start the Guest the first time.