Ktorrent stalls if left on its own

I’ve noticed this weird behavior where kTorrent would just stall downloading stuff if left on its own for a few hours. Once you activate kTorrent window from the panel it just gets on with the job, changing status from “stalled” to “downloading” in a few seconds.

Could it have something to do with the external disk I’m downloading on (some of the downloads, not all) being physically different one and connected via usb but mounted in a home directory?

I suspect this because Windows machine connected via samba also loses connection after a while as if there’s some “time expiration” set on mounting drives into home.

Here is the fstab line for the suspected mount:

/dev/disk/by-id/usb-Seagate_FreeAgentDesktop_3QK0A0N7-0:0-part1 /home/stan/Seagate ext2 acl,user_xattr 1 2

Could be HD spin down but I would have though that shouldn’t happen if it’s in use.

Or what about powersave/screensave settings

I would have thought involving Samba in any torrent downloads was typically a good idea, but I don’t use Samba. I do run torrents on a sever with a remote machine via ssh -X, and have no issue. Quite different I know.

Oh, yeah, the HD “spin down” is what I want to hear more about. I suppose torrent download CAN put it out of use if there’s no activity for a while.

I have another external HD connected via USB that seems to display “spin down” effect or something when mounted but I have commented it out from fstab altogether. When it’s mounted it could take half a minute for Delphin to display itself while I can really hear the disk being activated.

What is this “spin down” effect afterall?

Samba is not involved in any downloads, afaik, it’s just that I noticed that when its down, ktorrent is down, too. Need more investigation on this connection, though.

Just a casual observation, the only connecting point for me is the status of the mounted disk. If ktorrent things it’s down, samba, I suspect, thinks its down, too.

Spin down allows the HDD to stop working but AFAIK it doesn’t unmount it.
I don’t know enough about this subject to start advising you.
I do know you shouldn’t need USB drives in fstab though!

hdparm; is what is involved
man hdparm; in a terminal will give you the manual

I unmounted and removed one external disk from fstab, the one that was audibly spinning down and up, and the issue has gone away.

Should an external drive be in fstab at all? I’ve heard “it shouldn’t” a few times but it’s a pain in the ass to manually mount it after every boot and I was caught a million times firing off ktorrent, or even simply clicking on a torrent file in my browser, and then getting an endless stream of “cannot locate files” errors because I forgot to mount the drive first.

By “forgot to mount” I mean click on it in notification icon or Dolphin, not necessarily mount it from terminal.

My solution was to put it in fstab, if there’s something else I would like to hear it.

It should not be in fstab
Change the settings in kde to auto mount
System Settings > Removable Devices, check to auto mount

Ok, but that mounts it into /media into a generic “disk-1” directory, with “disk” being reserved for a windows partition on the same external disk that I have no intention of auto mounting.

Is there a way to always mount it into a designated folder in “home” instead?

Give the Disk a Label (Volume Label)
I use Parted Magic

For example one of my USB HDD’s is ELEMENTS
And it always mounts in /media/ELEMENTS

I understand neither Gparted nor Suse’s partitioner can assign labels to disks. Ok, downloading Parted Magic now, but shouldn’t there be a way to automount the disk exactly where I want it to?

Fstab did that for me.

If the disk mounts outside home directory there needs to a separate Samba share and Linux machines on the network need a separate fuse script to access it. No big deal but not the most elegant solution either.

I would even consider writing a small script to mount it into home and then run the script at start up if there’s no way to tinker with automount.

Having a volume label sounds like a useful idea regardless, thanks.

Stan - I don’t know enough about this. You need someone like @hcvv

Here is step by step example


Using Parted Magic an Introduction

Well, I’ve labeled the partition, it mounted in /media, but now I can’t figure out how to mount it with fuse from another Linux machine.

sshfs root@hostname takes me to root home directory, not to root per se and so media directory in inaccessible.

I can navigate to it if I simply ssh into the machine and cd around but can’t figure out sshfs shortcut yet. Any help with this?

I think I’ve figured it out, it’s root@hostname:/…/media/