ksshaskpass installation doesn't install any bin file

ksshaskpass5 has been installed but there is no ssh-askpass or related file found in /usr/bin. I’ve tried reinstalling but still doesn’t work.

Hello and welcome to the openSUSE forums.

Please explain how you installed and from where. That is not obvious from your post.

Also we have a place yo upload long computer texts and images: https://susepaste.org/
(not everybody ios willing to open files on a commercial site).

Shorter text can be posted here using CODE tags. It is an important, but not easy to find feature on the forums.
It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

An example is here: Using CODE tags Around your paste.


Checking here, on a Tumbleweed system:

“/usr/libexec/ssh/” contains:

Checking my environment, I find:


The script that I use for loading a key, sets


in the environment (if my desktop is KDE), and the result is that “ksshaskpass” is called for the password.

An addendum to my last comment.

The installed “ssh-askpass” is actually a script, which should call “ksshaskpass” if you are running KDE. Otherwise it calls “gnome-ssk-askpass”. And I think both “ssh-askpass” and “gnome-ssh-askpass” are installed by (or pulled in by) installing “openssh”.

Whether any of it works may depend on whether you have a “.ssh” subdirectory under your HOME directory.