KPPP Permissions issue for /usr/sbin/pppd

I am installing a USB Aircard on my MSI Wind which is running OpenSUSE 11. I thought I had to install a driver for it but when I plug it in it appears OpenSUSE 11 is recognizing the card and showing a driver is there. It seems the issue is getting it to actually use this driver and connect. I’m relatively new to Linux but figured I can use KNetwork Manager like I do for Wi-Fi but later used the following post suggesting KPPP:

Sierra Aircard 881 USB + Linux? - PC Cards - Wireless Forums from AT&T

Open Kppp
hit the configure button
on accounts tab create new account
connection name: “aircard” or whatever you desire
phone number: 99**1#
auth: pap/chap

on the modems tab
hit the “new” button
name your modem
*modem device: /dev/ttyUSB2
now click on modem tab
uncheck wait for dial tone
hit the modem commands button
init1 box enter: AT+CGDCONT=1"IP,“isp.cingular”
hit the query modem button
it should recognize and return info about the modem
will get you connected

Here is the issue I’m having. KPPP wasn’t on my distribution so I downloaded it from the repositories. After doing that I tried all the above but ran into some problems. The modem was on USB0 so I changed it to dev/tty/USB0.

The problem is after I installed KPPP and opened it up it said that I don’t have sufficient permissions to run:
Then below it says:
Make sure that KPPP is owned by root and has the SUID bit set.

What exactly does that mean? It seems I have to change permissions somewhere but since I’m a newbie I don’t understand what I have to do.

The next issue is I then follow all the procedures as I pasted above but then when I follow the procedure where it says to hit the query modem button it says: “Unable to create modem lock file.”

It appears I have everything set up but could this be because of the insufficient permissions or is this 2nd issue unrelated?
Even though it gives the original permissions error message it seems to run the KPPP Program but I assume even though it’s running it’s not working correctly.

Any idea how I can fix this or is there even another connect program that I should use instead of KPPP to use my USB 881 Connect Aircard for AT&T?
This is my original post:
Problem getting AT&T USB Connect 881 working on OpenSUSE 11 - openSUSE Forums

Go here:

I recommend that you begin by logging into your system as ‘root’. Configure your broadband device as you did above, and then test it. With luck you’ll find that you can connect without a hitch.

Once you’ve confirmed that the configuration is valid for your device, you will need to make a simple change to file permissions so KPPP can be run in ‘user’ mode. Let me explain.

As a user, you should already be a member of the ‘dialout’ group. If you look at the file permissions of PPPD (/usr/sbin/pppd), you should see that it is owned by User: root | Group: dialout.

When you launch KPPP (/usr/bin/kppp) it calls PPPD. By default, however, OpenSUSE does not hand off the proper level of credentials from KPPP, and so you receive the message, “You do not have sufficient permission to run /usr/sbin/pppd…”

While logged on as ‘root’, open Dolphin, navigate to /usr/bin/kppp, right click on the file, and select Properties from the context menu. Click the Permissions tab and then the Advanced Permissions button. In the “Special” column, click the box next to Set UID.

I know this can probably be done from the command line as well, but I don’t know the proper syntax offhand and a Google search failed to turn up the answer quickly. You may want to take a look at this document as well:

It has a great set of step-by-step instructions with screen shots which describe installation and configuration of KPPP on a Gnome desktop (Ubuntu). Although published by Sprint, I have found that the instructions are fairly generic and can be used for a wide range of devices from a variety of ISPs on an array of Linux desktops.

The procedure I described above still doesn’t work for OpenSUSE 10.3, so I guess I need to get my primary system upgraded to OpenSUSE 11. I’m just thrilled to have mine working now. (Mac & Windows users wrinkle their noses when I launch a command script to use broadband wireless.)

maybe open a term and type su at the prompt, enter your root password then at the root prompt enter:

kppp &

I use an aircard and used to use a dial up modem, so am very familiar with these types of connections.

KPPP won’t run without root or superuser permissions, and so I just abandoned it quite while back. Wvdial is the same way.

The best way I have found is to use kinternet. If you install kinternet and then run the set up dialog at YAST / Network Devices / Modems that should work fine.

Both KPPP and wvdial use pppd so they have the same ‘permissions’ problem.
Either set suid to pppd as explained in some link up here (chmod +s) or add your user to dialout group.