KPPP dies after connecting

I’ve gotten KPPP to connect, after Set UID on both /usr/sbin/pppd and /usr/bin/kppp. The error reports pppd terminated with error code 2. MAN pppd says this means there are conflicting arguments in the script. The modem is a USR external serial port, which works perfectly with earlier releases using kinternet or qinternet. Is there a compatible qinternet package?

Have you gotten all the updates? I believe that one recent update may address this

Thanks for the reply. I installed kppp15.08.3-3.1; once again I had to set UID on the new file. I get the same results: pppd terminated returning error #2. BTW I’m sending this from SuSE 13.1 on the same computer + modem, so hardware is ruled out as an issue.

  1. Any conflicting settings in your configuration? (If you want to share here, just leave out any authentication credentials)

  2. You could also try using qinternet. Install from here

The ‘unstable’ package should be fine to install/use.

  1. For test purposes, you could also try using the wvdial (CLI) utility.

Initial configuration is then done using


The basic configuration file can then be edited with the dial string and required authentication credentials in /etc/wvdial.conf

*For serial modem connectivity as user, you need to be a member of the ‘dialout’ group

I found qinternet; it requires smpppd, of which the latest version I could find is for SuSE 13.2. Zypper installed both RPM’s without complaint, but still no go. It does not activate the modem at all, because there is no way to input settings. The qinternent menu has the applicable parts grayed out. At this point I’ll have to give up on Leap. Without a working dial-up I can’t install updates from the SuSE repository since these are now “1 click” download and install. I still have other problems, e.g. no sound, Gnome does not work and freezes the system when started, etc.

That’s a shame. I would like to have seen your ppp config. There may have been something obvious causing this issue.

I’ll post it later. I have to copy the file to a memory stick to send it from a working installation. It appears the kppp configuration applet correctly configured, but now I suspect permission issues. After each failed attempt, the error message reports unable to create var/log/~ files. Also, the original kppp had “dialout” as group, but the update I installed is “root.” As I mentioned earlier, I had to set UID in pppd and kppp order to get kppp to activate my modem. The problem with qinternet seems to be it expects to be configured by YAST, but there is no routine to do that in Leap. I might note that kppp has always been a PITA in later Linuces; Debian just forgets it and recommends using PON and POFF.

I’d send you a copy if I could find it! It’s not in /usr/sbin or /etc/ppp. For that matter, there is no such file either in my SuSe 31.1, which is what I’m sending this from. Does it have a different name/location?

A long time since I used kppp. I installed it just for the purposes of assisting here. The kppp config file is ~/.kde4/share/config/kppprc

Thanks; found it. See below. Note “xxxx…” and “zzzz…” are where my actual password and logon go. Any idea where qinternet has its config file? [Account0] AccountingEnabled=0 AccountingFile= Authentication=4 AutoDNS=0 AutoName=0 BeforeConnect= BeforeDisconnect= CallbackPhone= CallbackType=0 Command= DNS= DefaultRoute=1 DisconnectCommand= Domain= ExDNSDisabled=0 Gateway= IPAddr= Name=Earthlink Password=xxxxxx Phonenumber=3390020 ScriptArguments= ScriptCommands= StorePassword=1 SubnetMask= Username=eln/zzzzzzzzz VolumeAccountingEnabled=0 pppdArguments= [General] DefaultAccount=Earthlink DefaultModem=USR5686G NumberOfAccounts=1 NumberOfModems=1 PPPDebug=0 ShowLogWindow=0 [Graph] Background=255,255,255 Enabled=true InBytes=0,0,255 OutBytes=255,0,0 Text=0,0,0 [Modem0] BusyWait=0 Device=/dev/ttyS0 Enter=CR FlowControl=Hardware [CRTSCTS] Name=USR5686G Speed=57600 Timeout=60 UseLockFile=1 Volume=1 WaitForDialTone=1 [WindowPosition] WindowPositionConWinX=479 WindowPositionConWinY=456 WindowPositionStatWinX=479 WindowPositionStatWinY=456

That’s not easy to read. When posting output, it’s a good idea to use code tags. (Refer to the ‘#’ icon in the editor.)

I compared the file to the kppprc in my SuSE 13.1 install. The files are essentially identical. However, kppp did not work with 13.1 either, so I installed qinternet. If you can locate whatever qinternet uses to store its configuration, I may be able to hand poke in the settings from my working 13.1.

IIRC, qinternet relied on smpppd, which the former yast modem utility could configure, although this could be done by hand. I note that it is no longer available, apart from via a third-party repo. It comes with man pages (eg man smpppd.conf) that explain how to configure it.

Basic configuration.

          Configuration files for the interfaces.
          Configuration files for the providers.
          Socket to communicate with local frontends.
          Sockets to communicate with backends.

I’m going to suggest you install ‘wvdial’ instead. There is a graphical front-end for wvdial called ‘qtwvdialer’ available as well. However, I couldn’t find a Leap-specific package available, but did manage to download and install the rpm from here

This utility makes it easy to configure and connect to a modem device. (All I have at hand to play with is a mobile broadband device, but it works for test purposes.)

I installed wvdial and qtwvdialer, after much effort in hunting down dependencies. Qtwvdialer connects with my modem and dials out. It apparently connects, then hangs until timeout waiting for a carrier. If anyone else wants to try this, these are the files you will need. Install in the same order to meet dependencies. #libopenssl0_9_8-0.9.8x-9.1.5.x86_64.rpm #wvstreams-4.4.1-63.4.x86_64.rpm #wvdial-1.61-6.1.3.x86_64.rpm #qtwvdialer-0.4.5-2.1.x86_64.rpm Keep your DVD in the drive because zypper will ask for it to install another library.

Those dependencies are met automatically if installing via a package manager. I installed wvdial and the qtwvdialer packages with no further effort on my part. Your DVD was only required because you have the installation source disk still configured in your repo list, which is probably a good idea for those who can’t connect to the internet directly, but otherwise the installation repo is best disabled or removed.

This ‘how to’ is worth reviewing too

From the link you provided: “18.10 NO CARRIER This means that the analog sine wave (the carrier) from the other modem isn’t present like it should be. If you were already connected, this means that the connection has been lost. There may have been noise on the line or a bad connection. The other modem may have hung up on you for some reason: Perhaps the automatic login process didn’t work out OK. Perhaps PPP didn’t get started OK. Perhaps a time limit was exceeded.” From an error message after shutting down, it appears that “Perhaps PPP didn’t get started OK” is the problem I’m experiencing. As I’ve mentioned, the same physical setup connects properly with the other Linuces and Win XP on the same multi-boot system.

Since I cannot connect my Leap install via internet, I have to hunt down the required RPM’s from another system, and transfer them via a USB memory stick. I posted my procedure for the benefit of anyone else having the same problems. Zypper reported that one of the RPM’s - wvstreams~ - required me to insert the distribution DVD during its installation to fetch libdb~. BTW today I acquired and installed the complete repository - 4 DVD’s - and that may be a good idea for folks in the same leaky boat.

Qtwvdialer - wvdialer exits with error code 1. Extensive googling has failed to provide an explanation of this error and how to correct it. I think permission and file ownership issues are the problems, e.g. the error reporting that pppd must be owned by root and have the UID bit set. Another unpleasantry of Leap I discovered is that I cannot set the UID bit with a graphic file manager (as root, of course.) It looks like the change is made, but it does not save. I had to do it old school: chmod 4755 in a root terminal. BTW I just installed SuSE 13.1 on a “lab rat” system with an internal USR PCI hardware modem. YAST configured it and I was online in a few minutes with qinternet. I can only hope the developers will restore the YAST modem module in a later update.

Note you do need a net connection to get an update. The current install will likely not change until 42.2