KMixer - Master channel volume

Hi there!
Every time I reboot the PC, the master channel’s volume is set to 33%. (This is too low for me.)
Even when I set the volume to 80%, when I reboot the PC, the volume back to 33%.
I test this condition with the "Start " configuration of KMix has checked or not “Restore volumes on login”.

How can I set the volume in 80% every time I reboot the PC?

Thank you in advance.

First set the master volume as required

Then from within konsole

kmixctrl --save

followed by

kmixctrl --restore

The volume setting is then saved as the default and should be restored upon login…

Paul:
Thanks for answer.
I follow your procedure, but it didn’t work: After I reboot the PC, the volume is set to 33%.

Only other thing I can think of at the moment, is the restore service running?

systemctl status alsa-restore.service

There was a bug ( https://bugs.kde.org/show_bug.cgi?id=249180 ) related to kmixer not restoring the volume but I thought it had been resolved.

Could take a look here for anything helpful: https://en.opensuse.org/SDB:Audio_troubleshooting


adrian@ASIA:~> systemctl status alsa-restore.service
alsa-restore.service - Restore Sound Card State
   Loaded: loaded (/usr/lib/systemd/system/alsa-restore.service; static)
   Active: inactive (dead) since Sat 2014-11-22 22:12:52 ART; 1h 6min ago
  Process: 856 ExecStart=/usr/sbin/alsactl restore (code=exited, status=0/SUCCESS)
 Main PID: 856 (code=exited, status=0/SUCCESS)



Is this OK?
I don’t know ALSA.

Thnks, again.

Yes, the restore service started at boot, (should have) restored the setting, and then exited.

Only one other thing I can think of… possibly an application is setting it’s volume to < master setting. By making the following change applications can have (their own) volume settings independent of the master volume.

You’ll need root privileges, first make a backup copy of “daemon.conf”, located at “/etc/pulse/”.

Then find the line:

; flat-volumes = yes

uncomment the line and change to no

flat-volumes = no

Save the file and reboot for the change to become effective.

Failing that, I’m sorry, I’ve no further ideas other than to try the suggestions in the bug report I linked to earlier. Specifically 249180 – KMix does not restore volume when logging in and onwards.

If that fails still, then I’d open a new bug report.

I have tried modify “/etc/pulse/daemon.conf” as you said, but the problem persist.
Thank you very much.

On 11/23/2014 09:46 PM, aecordoba wrote:
>
> tannington;2678359 Wrote:
>> Yes, the restore service started at boot, (should have) restored the
>> setting, and then exited.
>>
>> Only one other thing I can think of… possibly an application is
>> setting it’s volume to < master setting. By making the following change
>> applications can have (their own) volume settings independent of the
>> master volume.
>>
>> You’ll need root privileges, first make a backup copy of “daemon.conf”,
>> located at “/etc/pulse/”.
>>
>> Then find the line:
>>>
> Code:
> --------------------
> > > ; flat-volumes = yes
> --------------------
>>>
>> uncomment the line and change to no
>>>
> Code:
> --------------------
> > > flat-volumes = no
> --------------------
>>>
>>
>> Save the file and reboot for the change to become effective.
>>
>>
>> Failing that, I’m sorry, I’ve no further ideas other than to try the
>> suggestions in the bug report I linked to earlier. Specifically
>> https://bugs.kde.org/show_bug.cgi?id=249180#c58 and onwards.
>>
>> If that fails still, then I’d open a new bug report.
>
> I have tried modify “/etc/pulse/daemon.conf” as you said, but the
> problem persist.
> Thank you very much.
>
>

Did you reboot the computer/restart pulseaudio? See any errors?


openSUSE Factory 64 bit
KDE 4.14.1

On 11/20/2014 07:16 PM, aecordoba wrote:
>
> Hi there!
> Every time I reboot the PC, the master channel’s volume is set to 33%.
> (This is too low for me.)
> Even when I set the volume to 80%, when I reboot the PC, the volume back
> to 33%.
> I test this condition with the "Start " configuration of KMix has
> checked or not “Restore volumes on login”.
>
> How can I set the volume in 80% every time I reboot the PC?
>
> Thank you in advance.
>
>

Also have you tried this with veromix? I personally prefer it to kmix
and using it can help us determine if it is a KMix issue or if it is a
pulseaudio thing.


openSUSE Factory 64 bit
KDE 4.14.1

I don’t know veromix!

Is is a KDE based widget that’s live in the system tray. It does about the same as pavolcontrol but is handier since you don’t have to start an app since it is in the tray.

Both allow control for each app that uses the sound system so you can set input/output and levels for each app separately. So you could set a player to go to a channel that feeds into you amp and stereo sound system but have the system sound come over the machines sound or maybe head phones. In any case there are lots of options on how you can sett things up. Depending on your hardware limits.