Kill switch problem

Dell Inspiron 1501 AMD 64x2Turion 120GB HD,2GB RAM
Running WinXP,Ubuntu 7.10,Dreamlinux 3.5,Slax 6.03,Suse 11.1 in multiboot from Ubuntu’s Grub -no problems there.

I used to have Suse 10.3 here and had no problems installing wireless with ndiswrapper.
Now I switched to 11.1,installed ndiswrapper,installed the driver(bcmwl5) and blacklisted the b43 driver.
Everything goes smootly,but I can’t get a connection because Suse refuses to turn my wireless card on.
In this machine you can turn it on with the Fn-F2 key combination if it doesn’t spring on automatically at boot(what it is supposed to do)With Suse11.1 it is blocked in the on or off position and no way to get it working.
Finally after 2hours of editing and re-editing the network and rebooting a lot the wifi light on the PC springs on and I have my connection immediatly.
I don’t know if it’s because I did something or it just went on like that.I didn’t have that problem with Suse 10.3.
Does anybody have a similar problem and is there something I can do?
Here is my lspci -v when everything is working

05:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
        Subsystem: Dell Wireless 1390 WLAN Mini-Card
        Flags: bus master, fast devsel, latency 0, IRQ 18
        Memory at c0200000 (32-bit, non-prefetchable) [size=16]
        Capabilities: [40] Power Management version 2
        Capabilities: [58] Message Signalled Interrupts: Mask- 64bit- Count=1/1 
        Capabilities: [d0] Express Legacy Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
                UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF-
 MalfTLP- ECRC- UnsupReq+ ACSVoil-
                UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF-
 MalfTLP- ECRC- UnsupReq- ACSVoil-
                UESvrt: DLP+ SDES- TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+
 MalfTLP+ ECRC- UnsupReq- ACSVoil-
                CESta:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
                CESta:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
                AERCap: First Error Pointer: 14, GenCap+ CGenEn- ChkCap+ ChkEn-
        Capabilities: [13c] Virtual Channel <?>
        Kernel driver in use: ndiswrapper
        Kernel modules: ssb

Any ideas would be welcome. Thanks[/size]

probably because you are using ndiswrapper. the new b43 driver is much better & works very well. See the stickies for installing it.


Well,strangely enough it started to work a little while after I posted!I booted/rebooted 3-4 times now without problems.Wifi switch is on and I get wireless immediately.So I will keep this configuration for the moment.

I usually get my wireless with ndiswrapper(tried 14 distro’s with it)but if b43 is getting better it certainly is worth switching.
I remember I used b43 last year on Fedora FC8(couldn’t get ND to work)and it worked but was much slower than what I usually get with ndiswrapper and that’s why I stick with it.

I ran Suse 10.2,10.3 and 11.0 with ndiswrapper so I didn’t really look for b43 and fwcutter(maybe I should have)and went straight for ndiswrapper.
Anyway,if I run into problems again,I’ll try b43.I’ll have to remove ND first because it uses another kernel of course.