Keyboard special keys for audio not working openSUSE 11.4

Hello everybody!

I’ve been making some progress with my new Dell Inspiron n5110 and the OpenSUSE 11.4.
After searching through the net I found some drivers to get my laptop going.

Now I’m facing the following problem: I want to adjust the audio volume using a special key combination on my laptop(fn+F11 to rise, fn+F12 to lower, and another key that works as mute). Although the sound itself works fine, when I use these keys the have no effect on the volume. It stays exactly the same. Some I ask myself are the drivers for the sound card installed?
In “Playback Devices” there are two devices: Internal audio analog stereo(which is the one that is working) and GF108 High Definition Audio Controller Digital Stereo(HDMI).

The lsusb provides:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 8086:0189 Intel Corp.
Bus 001 Device 004: ID 1bcf:2880 Sunplus Innovation Technology Inc.
Bus 002 Device 003: ID 0bda:0138 Realtek Semiconductor Corp.
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

So I searched for some Realtek drivers and came up with nothing.

If you have any idea on how to get my audio running or how to make the special keys working, please let me know!

P.S. I’m sorry if this is a question for 2 separate threads.

I’m having the same issue on my dell d610. I get sound at full volume out the speaker but have not controls via keyboard (fn-PageUp/fn-PageDown) or software controls.
My hardware is:
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC’97 Audio Controller (rev 03)
any help appreciated!

On 05/28/2011 09:06 PM, mikejarvis wrote:
> I’m having the same issue on my dell d610.

since volume control via keyboard works perfectly here i must assume
this to be a Dell hardware problem which is not adequately addressed by
the driver…suggest you look to Dell user forums to learn how the
Dell crowd solves the problem…

or, maybe send Dell nice toned note asking them to help change the
driver to also suit their hardware…

if you find relief, please tell us about it…(so, the next dell users
who googles into this thread can also smile…

[NNTP via openSUSE 11.4 [] + KDE 4.6.0 + Thunderbird 3.1.10]
Dual booting with Sluggish Loser7 on Acer Aspire One D255

the symptoms are that the volume works for applications at full volume only and I can not adjust the settings either via software or keyboard (function key) …I’ll post a fix if I ever find one!


In KDE’s systemsettings: Input Devices - Keyboard - Keyboard model. There’s a lot of Dell models, maybe one works for you

I am not sure if I had the same problem as you. But my sound worked but the keys were not working.

When I went to the mixer (click on the sound icon in the bottom right>mixer), I could see two different channels.

I simply went to the Settings>Select Master Channel and switched it to the other one. And now my keys work.

Since I upgraded to 11.4 neither the buttons on the front of my Inspiron 6000 nor the Fn+PageUp or PageDn options work. I have sound but the only way to control it is Yast> Hardware> Sound (a little cumbersome to say the least). There is no “Mixer” icon on my screen and I cannot find one to install.

Any ideas gratefully received. :shame:

Re above:
I found KMix and added the launcher. After playing with the Settings> Configure KMix an icon appeared in the system tray and the buttons started working as before.

On my route I also tried to install parvucontrol. It downloaded and compiled but the command


a msg said “Connection denied”. I guess that is a conflict with KMix? Not very scientific but I got there.


Thank you, thank you, thank you! My problem got solved! I had this problem also in KDE on Ubuntu (and of course with openSUSE 12.3 with KDE 4.10). My laptop is a Dell Studio 1535 (produced in 2008). I want to say a BIG thanks! I couldn’t find this solution anywhere else!