Keyboard and touchpad lock at installation on ASUS UX303U


I encountered the following problem yesterday at LEAP 15.1 installation.

I decided to upgrade my 15.0 to 15.1 via fresh installation from DVD. Everything went fine till the screen with language choice. I noticed I could not write anything in verification field, also touchpad was not active. I finished the installation with USB mouse and after system start the keyboard and touchpad both were dead again.

When I plugged in external USB keyboard and mouse they worked fine. Only built in keyboard and touchpad were not active.

I tried to start the system from Live CD - the same. In GRUB I could use the keyboard to choose the option, but when Opensuse took over the control it disactivated keyboard and touchpad.

Then I prepared DVD for network installation. The same. The keyboard was active in GRUB and shortly afterwards (I checked with lighted CAPS LOCK). Then after installer took over control it locked the keyboard.

My last step was to reinstall version 15.0 from DVD for network installation. It went perfect and all works fine. So I use 15.0 writing this post.

But I would be grateful to learn what makes such keyboard and touchpad issue in 15.1 …

You may need to add ‘i8042.reset’ to your grub boot configuration. From a quick search online some users with similar ASUS hardware report needing one or more of the following boot parameters ‘i8042.reset i8042.nomux i8042.nopnp i8042.noloop’ (which will depend on the exact hardware configuration deployed in a given device).

This openSUSE guide shows how to test these at the grub boot screen on the fly…

in my case i8042.nopnp helped. Now works perfectly. Thank you very much deano_ferrari.

it turned out not everything was perfect :frowning:

This setting enabled me to upgrade the system and use it. But when I tried to change the keyboard backlight or screen brightness or set the airplane mode I realized I cannot use the keyboard FN key shortcuts to do it

Trying to find out the solution I noticed that when I go to advance options in GRUB and start the Leap 15.1 with the elder Kernel version 4.12.14-lp150.12.82-default, no matter if I set the i8042.xxxxx GRUB boot options or not - the system works perfect: both keyboard and touchpad are active and all FN shortcuts work.

If I start Leap 15.1 with kernel 4.12.14-lp151.28.36-default I need to set i8042.xxxx options but I loose keyboard control over keyboard backlight, screen brightness or airplane mode. The brightness setting with mouse works fine, so it is not the problem with video driver.

If it’s the same as on my daughter’s Zenbook, it doesn’t work like that on these machines. If all is well she’s dropping in later today, I’ll ask her.

I guess you made a typo … lp150 is a Leap 15.0 kernel which Leap 15.0 never had. Can you confirm this? If so, file a bugreport.

no, it is not typo. After upgrade I have five grub starting options for Leap 15.1. See the screenshot.

I have to correct myself, should have checked better. It IS Leap 15.0s kernel, which is still on your system since the system cleans up older kernels, but you never reached that point yet after the upgrade.

I don’t know if it may be relevant, but on one of my ASUS laptops I need the “acpi_osi=Linux” boot option to use some Fn keys, including keyboard backlight.
It is firmware-dependent, so your mileage might vary. Also, I don’t have problems with the i8042 and don’t know if that has a role.

unfortunately “acpi_osi=Linux” has not helped. Still the 15.1 kernel is not usable for me :frowning:

But it looks strange that the system works with the elder kernel (happily not erased) and makes problem with the new kernel. All settings are the same, so it looks like new kernel bug, or…?

Despite the very similar look of the two kernel versions, it is likely that the newer kernel includes backports of a few drivers, possibly i8042 or whatever, so that driver might be more similar to a 5.x kernel now and the possibility of a bug in the (openSUSE port of) the kernel is a possibility.
If a different i8042 boot option doesn’t work, a report in bugzilla might be the way to go

I have zenbook ux310uq and similar issue. I already reported to Bugzilla.

The situation got even worse. After yesterday kernel upgrade the 15.0 kernel disappeared from boot options and now it shows also plenty of ACPI errors and I lost also battery indication.

I am wrting this on my UX303UB.206 and it’s been working next to perfectly ever since I bought it in 2016. Running Tumbleweed, though. I hardly use Fn keys but keyboard backlight works, screen brightness works, audio volume works.

Finally the problem is solved :slight_smile:
Upgrading to Leap 15.2 made everything work as expected…