keyboard and mouse lost after update - how to boot in to terminal?

Hi all,

I was working on something important in 11.2 and did a “zypper up” in the terminal in the background. I wasn’t paying that much attention to it, I believe it was an update to 11.3. After returning to the computer after about one hour the windows were behaving strangely and the machine wasn’t very responsive. I decided to reboot. Now at login I have neither mouse nor keyboard. I have switched the keyboard to PS2 model, no difference. If someone could help me with booting to run level 3 from the grub menu perhaps I could change some settings there to make everything work. I really regret doing the update. It would be very important for me to be able to get back in to machine with spending as little time as possible on this. Could I reverse the update? This machine is very important for me and my family for their daily communication, but currently I have very little time to fix this. My quick fix was to install Kubuntu 10.10 so I could resume working, but I would really need to get back in to 11.2.

From the grub menu, just add a ‘3’ at the end of the line booting the kernel and press Enter.

Thanks. From the terminal I managed to complete the update with “zypper dup”. Unfortunately the machine will not boot after that. “startx” never got any further than the screen with the frog with the white progress bar. When rebooting it can’t find the kernel. Fortunately I can access the data from the Kubuntu installation. I guess I don’t have the knowledge for resolving this issue.

It is possible to access the boot directory on the opensuse machine, if that is of any help…

I don’t understand what you mean. If you’re able to type ‘startx’, then the system has booted already. The kernel is the file named vmlinuz-xxxx in the /boot directory. There should also be ‘vmlinuz’, which is a symlink pointing to the kernel, as well as a initial root file system image called initrd-xxx and its symlink initrd.

If startx fails, there is a problem with the Xorg configuration or a with the a driver, more likely the video driver. Look in the file /var/log/Xorg.0.log to see what went wrong.

If /boot/grub/menu.lst contains the correct boot entries for openSUSE, running the command update-grub under Ubuntu (not openSUSE) will add them in the Ubuntu grub menu.

On 2010-10-15 10:36, jan-henrik wrote:
>
> Hi all,
>
> I was working on something important in 11.2 and did a “zypper up” in
> the terminal in the background. I wasn’t paying that much attention to
> it, I believe it was an update to 11.3.

Impossible.

To upgrade from 11.2 to 11.3 you have to manually change the repositories, and then do a “zypper
dup” - not “zyper up”.

You have to pay attention to what zypper says it is going to do. Do not simply press “enter” to
whatever questions it says. This is not windows, you are responsible for your acts as administrator.
If you are not sure, then use yast/update - and still you have to check it over before clicking [OK].

> If someone could help me with booting to run level 3 from
> the grub menu perhaps

Type a “3” at grub.

> Could I reverse the update?

Perhaps - when we know what you really did.

Check:

/var/log/zypper.log
/var/log/zypp/history

> This
> machine is very important for me and my family for their daily
> communication, but currently I have very little time to fix this. My
> quick fix was to install Kubuntu 10.10 so I could resume working, but I
> would really need to get back in to 11.2.

If you installed kubuntu on top, it is impossible to go back or repair.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

You are correct regarding my terminology of starting X. It was and still is startx that fails. With the help of “update-grub” I am once again able to get to the terminal with 2.6.34-12 but then startx tells me there is no screen.

I think the below exceprt from the Xorg.0.log may tell us there are several things wrong. Mainly the lack of nvidia drivers and what about the lines in the beginning regarding keyboard and mouse. That was the initial problem that set everything off…

I am very grateful for your help and patience.

85.046] (==) ModulePath set to "/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"
85.046] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
85.046] (WW) Disabling Keyboard[0]
85.046] (WW) Disabling Mouse[1]
85.046] (II) Loader magic: 0x7d58a0
85.046] (II) Module ABI versions:
85.046] 	X.Org ANSI C Emulation: 0.4
85.046] 	X.Org Video Driver: 7.0
85.046] 	X.Org XInput driver : 9.0
85.046] 	X.Org Server Extension : 3.0
85.050] (--) PCI:*(0:6:0:0) 10de:0a20:1458:34d6 nVidia Corporation GT216 [GeForce GT 220] rev 162, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xce000000/33554432, I/O @ 0x0000ec00/128, BIOS @ 0x????????/524288
85.051] (II) Open ACPI successful (/var/run/acpid.socket)
85.051] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
85.051] (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
85.051] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
85.051] (II) "record" will be loaded by default.
85.051] (II) "dri" will be loaded by default.
85.051] (II) "dri2" will be loaded by default.
85.051] (II) LoadModule: "dbe"
85.051] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
85.051] (II) Module dbe: vendor="X.Org Foundation"
85.051] 	compiled for 1.8.0, module version = 1.0.0
85.051] 	Module class: X.Org Server Extension
85.051] 	ABI class: X.Org Server Extension, version 3.0
85.051] (II) Loading extension DOUBLE-BUFFER
85.051] (II) LoadModule: "glx"
85.052] (II) Loading /usr/lib64/xorg/modules/updates/extensions/libglx.so
85.060] (II) Module glx: vendor="NVIDIA Corporation"
85.060] 	compiled for 4.0.2, module version = 1.0.0
85.060] 	Module class: X.Org Server Extension
85.060] (II) NVIDIA GLX Module  256.53  Fri Aug 27 20:50:26 PDT 2010
85.060] (II) Loading extension GLX
85.060] (II) LoadModule: "extmod"
85.061] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
85.061] (II) Module extmod: vendor="X.Org Foundation"
85.061] 	compiled for 1.8.0, module version = 1.0.0
85.061] 	Module class: X.Org Server Extension
85.061] 	ABI class: X.Org Server Extension, version 3.0
85.061] (II) Loading extension MIT-SCREEN-SAVER
85.061] (II) Loading extension XFree86-VidModeExtension
85.061] (II) Loading extension XFree86-DGA
85.061] (II) Loading extension DPMS
85.061] (II) Loading extension XVideo
85.061] (II) Loading extension XVideo-MotionCompensation
85.061] (II) Loading extension X-Resource
85.061] (II) LoadModule: "record"
85.061] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
85.061] (II) Module record: vendor="X.Org Foundation"
85.061] 	compiled for 1.8.0, module version = 1.13.0
85.061] 	Module class: X.Org Server Extension
85.061] 	ABI class: X.Org Server Extension, version 3.0
85.061] (II) Loading extension RECORD
85.061] (II) LoadModule: "dri"
85.062] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
85.062] (II) Module dri: vendor="X.Org Foundation"
85.062] 	compiled for 1.8.0, module version = 1.0.0
85.062] 	ABI class: X.Org Server Extension, version 3.0
85.062] (II) Loading extension XFree86-DRI
85.062] (II) LoadModule: "dri2"
85.063] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
85.063] (II) Module dri2: vendor="X.Org Foundation"
85.063] 	compiled for 1.8.0, module version = 1.2.0
85.063] 	ABI class: X.Org Server Extension, version 3.0
85.063] (II) Loading extension DRI2
85.063] (II) LoadModule: "nvidia"
85.063] (II) Loading /usr/lib64/xorg/modules/updates/drivers/nvidia_drv.so
85.063] (II) Module nvidia: vendor="NVIDIA Corporation"
85.063] 	compiled for 4.0.2, module version = 1.0.0
85.063] 	Module class: X.Org Video Driver
85.065] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
85.065] (EE) NVIDIA:     system's kernel log for additional error messages.
85.065] (II) UnloadModule: "nvidia"
85.065] (II) Unloading /usr/lib64/xorg/modules/updates/drivers/nvidia_drv.so
85.065] (EE) Failed to load module "nvidia" (module-specific error, 0)
85.065] (EE) No drivers available.
85.065] 

Fatal server error:
85.065] no screens found
85.065]

Thanks for your reply.

Kubuntu is running on its own partition, so as far as I know, the OpenSUSE installation is intact.

You are right about paying more attention to zypper. But after 6 months of the repomd.xml problem I have become too numb to what it posts.

On 2010-10-15 12:06, please try again wrote:
>
> jan-henrik;2238253 Wrote:
>> “startx” never got any further than the screen with the frog with the
>> white progress bar. When rebooting it can’t find the kernel.
>
> I don’t understand what you mean. If you’re able to type ‘startx’, then
> the system has booted already.

He may be typing startx at grub… :open_mouth:

And if he really did a “zypper dup”, then all bets are off :-/


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Now you see what’s the problem. The video driver is not installed properly and the module is missing. If you have the file /etc/X11/xorg.conf, edit this file as root and replace the line
Driver "nvidia"
with
Driver "nouveau"

See if it makes a difference when you do ‘startx’. If it works, that would be the fastest solution.

Otherwise you have to install the nividia driver. There are two or three ways to do it, all widely explained in this forum (and in the hardware subforum).

Actually you’re on 11.2. I don’t remember if nouveau was installed by default on 11.2 …:frowning:
You can use nv instead of nouveau in that case and reinstall nvidia as soon as you have 5 minutes.

@please_try_again is 100% right. No other problem than the nvidia driver, symptoms are all related to this. I strongly suggest, you (re)install the NVIDIA driver:

Start the system with “3” on the boot options line
In the console, log in with username and password
Type


su -c yast
(enter root password)

You can move around with the TAB and arrow keys, mark things with the spacebar.
Start Software - Software repositories
Pick Add
Mark Repositories maintained by the Community, Next,
Mark the NVIDIA repo, Next, OK

You now have added the repository for the NVIDIA driver packages. Next you need to install them:

Start Software - Software Management
If all is well , two packages will be auto-selected for install. Accept, and let the installer do it’s thing. If not, get back here, we’ll help you through.

Reboot and you should be able to enter a shiny openSUSE desktop experience. Enjoy

It took some time for me to understand why vi was not working, the keyboard layout was wrong. Anyway, I did change nvidia to nouveau in xorg.conf and now the mouse and keyboard are working.I am also able to login again! thanks guys.

My next problem is that I shrunk the the partition for opensuse when installing kubuntu. Nope I can’t rationally explain this choice either, I thought the opensuse installation was lost and that I wouldn’t have time to try to fix it.

I am now installing gparted in kubuntu in order inflate it again.

I’ll keep you posted.

cfdisk gives me this:

FATAL ERROR: Bad primary partition 3: Partition ends in the final partial cylinder
Press any key to exit cfdisk

[QUOTE=Carlos E. R.;2238274]On 2010-10-15 10:36, jan-henrik wrote:
>

Type a “3” at grub.

> Could I reverse the update?

Perhaps - when we know what you really did.

Check:

/var/log/zypper.log
/var/log/zypp/history

>

/var/log/zypper.log

the above log is empty.

/var/log/zypp/history

should i be able to find the command i gave in zypper from there? i know that it was not “zypper dup” but i can’t find the exact command from the above file.

I am able to delete the kubuntu partition in gparted. this would be only way to free space for the opensuse partition. before i do this, what will the consequences for grub be?

thanks again.

Very bad if you’re using Ubuntu’s Grub, no problem if you’re using openSUSE Grub. To be safe, install/reinstall openSUSE Grub in MBR. If your /boot directory is on partition sda5 (for example) , type the following in a terminal :

grub
root (hd0,4)
find /boot/grub/stage1   (should display (hd0,4) )
setup (hd0)

If it’s on sda2, take (hd0,1), sda3 -> (hd0,2), etc.

On 2010-10-15 14:36, jan-henrik wrote:

>> /var/log/zypper.log
>>
>> the above log is empty.

What about compressed backups?

>> /var/log/zypp/history
>>
> should i be able to find the command i gave in zypper from there? i
> know that it was not “zypper dup” but i can’t find the exact command
> from the above file.

The command might be in Mr. Root .bash_history. The results are in the logs above. The last one
lists every thing you installed, upgraded, removed, and when.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Ok. I will enter the opensuse terminal and take a look at that. I should have time for it later today or tomorrow.

THanks