Kernel wakeups

I am using powertop to see power consumption of my notebook. It’s info from powertop:

Top causes for wakeups:
46,4% (707,3) <kernel core> : hrtimer_start_range_ns (tick_sched_timer)
18,2% (277,8) <interrupt> : PS/2 keyboard/mouse/touchpad
12,2% (185,6) <kernel IPI> : Rescheduling interrupts
3,9% ( 60,1) <interrupt> : uhci_hcd:usb3, nvidia
3,2% ( 48,4) kwin : hrtimer_start_range_ns (hrtimer_wakeup)
2,7% ( 40,9) npviewer.bin : hrtimer_start_range_ns (hrtimer_wakeup)
2,5% ( 38,5) <interrupt> : extra timer interrupt
2,3% ( 34,5) <interrupt> : iwlagn
2,1% ( 32,5) Xorg : hrtimer_start_range_ns (hrtimer_wakeup)
2,0% ( 29,8) firefox : hrtimer_start_range_ns (hrtimer_wakeup)
1,3% ( 19,9) plasma-desktop : hrtimer_start_range_ns (hrtimer_wakeup)
1,0% ( 14,8) <interrupt> : ahci

You see that too many wakeups were made by kernel. It’s very strange! Is it a bug? :open_mouth:

DenerKup wrote:
> Is it a bug? :open_mouth:

no, i don’t think so…if you want it to sleep then click on
hibernate…otherwise, it will remain awake because it has lots of
housekeeping stuff to do, behind the scenes even when the user (you)
has no demands…

remember, this is an enterprise ready, industrial strength,
multi-user, multi-tasking kernel like the ones running in 89.2% of the
worlds top 500 supercomputers as of November 2009 (cite

that said, there are ways to make your kernel more thrifty with
power…but, that is far beyond my experience or need…on the other
hand you might want to search these fora for things you can do…they
run from simply setting your desired power usage wants (with, for
example Kpowersave); through turning off ‘services’ you don’t need
(each has their own demands on the kernel) up to custom compiling a
kernel specifically to meet your needs (the kernels distributed by the
openSUSE community are kinda ‘generic’ in that they should well serve
a broad spectrum of users, hardware and etc)…

i’m confident there are many post here and on the net that you might
find beneficial…