kernel update broke madwifi driver

I just updated my kernel to Prior to the upgrade, I was using the madwifi ath_pci module for my Atheros AR5001X+ wireless card. (I had tried ath5k and never could get it to work.) Since the kernel upgrade, the madwifi packages (from Index of /suse/11.1) claim to not be compatible with my kernel and yast suggests that I downgrade to kernel Not wanting to downgrade, I tried ignoring dependencies. Madwifi would install, but ath_pci was not available (FATAL: Module ath_pci not found.), only ath5k. So I uninstalled madwifi and tried compiling it from source, which also didn’t work. Finally I decided to downgrade my kernel just to get wireless working… the downgrade fixed madwifi, but it broke my nvidia drivers. After messing with that for over an hour via console, I ended up upgrading the kernel again to install the latest nvidia drivers… which leaves me where I started, with X working but no wireless.

Anyone know how I can get the madwifi drivers to work with the latest kernel? :\

Index of /repositories/driver:/wireless/11.1-update