Kernel / Repository issue 12.3 installation

I need some help with the installation of Suse version 12.3.
I had a GRUB dual boot setup allowing me to select between Windows XP (32bit) and Suse 11.1 which worked fine, however I wanted to update to Windows 7 and Suse 12.3.

First thing I did is a complete new installation of Windows 7 64bit version which is running fine.
I then wanted to install Suse 12.3 from a DVD I created from an ISO file but I am not getting pass the Loading of the Linux Kernel. I get an error message saying cannot find repository. It appears the DVD is not being recognized any more.

Did you run the self test on dvd and also before burning the iso do the hash check ?

First I did a hash check of the iso file and both the MD5 and SHA-1 signatures are matching up.
Following that I rebooted and selected “Check Installation Media” on the Boot Screen which immediately started loading the linux kernel.
I was then asked to “Insert CD-ROM or DVD”, however the DVD I booted from was still in the drive. This led to “Activating manual setup program”. Again, I tried to access the DVD from there with no success.

I then burned another DVD using a different burning software - to no avail.

OK 2 things to try Since you can get to a DE from root logon KDE is OK So it has to be something in your KDE cofiguration in your home. So first to try add a new user this can be done from command line and running the command line version of yast. Just type yast (as root) If the new user can log then there is something wonky in the ~/.kde4 directory. rename ( mv .kde .kde.old ) that in your home then try to log in . You will have to resetup your Desktop configuration unless you want to try move files from the .kde.old to the new .kde4 one by one until it breaks. Then you would know which file is bad. IMHO it is easier to just resetup your DE.

BTW I’d recommend not using auto login because it gets in the way when a problem occurs.

Sorry, not following you here. I actually can’t make it to a suse desktop environment unless the manual setup program is what you are referring to here - please confirm.

Can you boot to run level 3 (ie terminal)???

at boot press ‘e’ and find line that starts with linux go to end (press end key) enter a space then a 3 press F10 to boot

log on as root
type yast ( navigate via tab key)
go to users add a new user for test purpose
quit yast
log on as the new user
Still a problem???
if not then you have corrupt files in your ~/.kde4 directory
So press alt-ctrl-F1 to go to terminal log as you
navigate to you home directory if you are not already there (ie cd /home /yournamehere)
rename the ~/.kde4 directory
mv ~/.kd4 ~/.kd4.bak
type quit to close term session
press ctrl-alt-F6 to go back to GUI which is loged in as the new user
log out log back in as you see if that works now

Thanks for your further reply, but you lost me - I am simply not familiar enough with this.

In the meantime, I connected an external (USB) DVD drive and the installer is now successfully loading from that drive. I can select the Installation Mode, Time Zone etc, however no hard disc is found - means in addition to the internal DVD drive the hard discs are not recognized either. The installer suggests the following at this point:

  • No disc found. Try using the update CD, if available, for installation
  • Nothing assigned as root system
    In addition:
  • Check if you need specific hardware drivers for installation.

I will need to look into this tomorrow, however any suggestions/ tips are again appreciated.

I now figured that the hard disks are not found because the drivers of my NVIDIA GForce need to be added manually. I believe that I located the correct driver nvidia-gf6_gf7.ymp and I have downloaded it, but can’t figure out how to load it during the installation process/ boot.

Am I on the right track here? How can this be done?

There is no connection between the hard drive and the video driver. So you are wrong.

So I’m confused from your first post I thought you had already installed and the second boot was the problem.

So press F3 and select no KMS for a video problem at the install stage.

For the not found HD I don’t know. that is not a usual problem. Is this a new machine with UEFI or an older with a BIOS?

You may need to make a change in the BIOS but I forget the exact change maybe someone else remembers.

Sounds like a driver problem with the hard disk controller chipset of your motherboard, what kind of hardware are you running? You may also want to check your bios settings to look for compatibility settings for sata or ide hard drives. I do not think it has anything to do with the video drivers although that may also be a problem.

Here are the details on my system:

  • ACPI x64-based
  • Bios Version FUJITSU SIEMENS // Phoenix Technologies Ltd. 6.00 R1.06.2740.A2
  • SMBIOS Version 2.5
  • WDC WD5000AAKS-07A7b2 ATA Device
  • NVIDIA GeForce 7100/ NVIDIA nForce 630i
  • Optiarc DVD RW AD-7200s ATA Device

To follow up and provide closure to this thread:
Changing the Sata controller mode from compatible to enhanced in the BIOS resolved the issue.
I was able to install 12.3 and it is up and running.