Kernel panic while running on battery

I have a Dell Precision m6800 laptop. When running on AC, it is fine. When on battery, it hangs with a kernel panic (unresponsive and caps lock flashing). Sometimes, I can work for 15 or more minutes. Other times, I can barely get started before it occurs. As an example, this message is my third try at a posting; the first two had the panic occur before I could succeed.

Journalctl on the next boot does not have any info about the panic.

Because I am using KDE/X, I cannot get to a console to see a message.

How can I find the source of the panic to track back further?

It might be relevant that it seems that doing Internet work with WiFi is always occurring when the problem occurs. However, this might be a correlation and not causation.


My 2 cents: a degrading battery condition.

Seems unlikely, as I get around 6 hours of battery life. Also, why would that cause a kernel panic?

More to the point however, how can I get access to the kernel panic messages when running KDE? I do not see them on reboot in journalctl.

If you have another computer, ssh into the problem-computer an see any dmesg -w (-w to follow) during problem, then you can read some text even when problem computer locks.(other commands to read out problems, please fill in?)

dmesg -w

Rounding up one of the usual suspects I found this:
It’s an Optimus system, now Optimus mustn’t be the cause, but should be looked at. Have you installed bumblebee or prime, or possibly the Nvidia driver only?


I don’t by any means intend to hijack this thread, but I’ve got the same problem. Has anybody here reached any conclusion about why this issue occurred?

In my case I switched all my repositories to Tumbleweed ones, upgraded Leap 42.1 to Tumbleweed and after that the kernel panics started, once I try running or booting on battery.

I thought it’s about the kernel version 4.6.4 (or whatever the version was there), and I then downgraded back to Leap 42.1, using the previous repositories (or at least very close ones), but the kernel panics issue still remains. So I guess it’s not actually about the kernel’s version?

Any tips where to look here?

Check your lapttop manufacturer’s website, there’s probably a battery health utility somewhere on the site.

You should probably post how much physical RAM you have installed.
Personally, I feel uncomfortable running KDE on less than 4GB RAM, and prefer 8GB or more.
You might try installing and using LXDE or XFCE to see if a lighter load on system resources makes a difference(assuming you have enough disk space). openSUSE makes it easy to install and switch between Desktops. If you happy with KDE’s look and feel, I’d recommend LXDE over XFCE.

You should probably also run top (or run free periodically) to monitor system resource usage while you are using apps and see if after hours your system loses free resources. And, if you have “only” 4GB RAM, then close apps as often as possible, in particular FF, any java and flash apps.


The laptop has some Intel i processor and 8GB RAM. Its battery lasted a few hours easily. I really don’t think this problem is related to performance of the computer or the battery. Especially because this issue started right after upgrading OpenSUSE.

I also didn’t describe what really happens in my case - as soon as (I mean right at that moment) unplug power cable, laptop’s display starts flickering and the computer just hangs completely. When I try booting up without power cable, I just get kernel panic at some point. And always the same way. Should I maybe grab some dump or other error log somewhere?

Oh, and one more tiny detail - if I boot up with acpi=off then the system works fine.

So how it seems to me is that upgrading to Tumbleweed changed some ACPI setting on my system which caused my system to catch that bug in kernel or something. And when I downgraded back to 42.1 the setting remained and thus the buggy behavior too.