Kernel Dependencies

hi there
i am trying to get my wifi working and have been following the guide below. however when i try to install the kernel module (last thing) i get a failed dependencies error. here is the error with some other info:

#Mayhem:/usr/src/packages/RPMS/x86_64 # rpm -ihv madwifi-kmp-default-r3725+AR5007EG_2.6.25.16_0.1-2.2.x86_64.rpm

error: Failed dependencies:
kernel(default:vmlinux) = 3db9af7df68368aa is needed by madwifi-kmp-default-r3725+AR5007EG_2.6.25.16_0.1-2.2.x86_64

#Mayhem:/usr/src/packages/RPMS/x86_64 # uname -a

Linux Mayhem #1 SMP 2008-06-07 01:55:22 +0200 x86_64 x86_64 x86_64 GNU/Linux

i know it i something to do with different kernels but i am a novice at linux and have no idea what to do. Any help on resolving this matter would be wonderful!

here is the guide i am following:

Go to Index of /repositories/home:/schmolle1980/openSUSE_11.0
and look for the src (source) file tree =
Index of /repositories/home:/schmolle1980/openSUSE_11.0/src

download: madwifi-r3725+AR5007EG-2.2.src.rpm

copy/move it to: /usr/src/packages/SRPMS using filemanager-superuser-mode
Kmenu > System > File Manager > filemanager-superuser-mode

In a terminal as root; that’s:

cd /usr/src/packages/SRPMS
now do
rpmbuild --rebuild madwifi-r3725+AR5007EG-2.2.src.rpm
(wait until it compiles your rpms without error; look at the last few lines of code.
that will build the rpms and they will be found in /usr/src/packages/RPMS/x86_64. The rpms will match your kernel and system).
cd /usr/src/packages/RPMS/x86_64
rpm -ihv madwifi-r3725+AR5007EG-2.2.x86_64.rpm (if this is the 1st go with madwifi; else use)
rpm -Uhv madwifi-r3725+AR5007EG-2.2.x86_64.rpm (for update/upgrade)
then install the kernel module
rpm -ihv madwifi-kmp-default-r3725+AR5007EG_2.6.25.11_0.1-2.2.x86_64.rpm
(Same as above; except here you need to check your running kernel with “uname -a”
mine come up “default” so that’s the kernel module rpm I use).(meaning???:slight_smile:

Hmmm… In my opinion, you chose the most intricate way for making your wifi work. I don’t think you need to install a non-default kernel just to make your card work. It’s far simpler to go into YAST/Software/Install Software and search for madwifi; then you tick it and click install. After a reboot – and … uhm … some fine-tuning – your card (if it’s an Atheros card) should work.

ok so installed and rebooted

how do i “see” the card and scan for networks?


Well, the first thing would be to enter a Konsole, type su (and provide your root password) and then issue the commands
If you can post the results of those two commands, we could see if your wifi card is working, and then go on from there.


Sorry to just note your PM; been busy.

You need to make sure you have kernel-source, kernel-syms (that match your running kernel), gcc, C++, and make installed – then it should rebuild the src rpm.

do “uname -a” & if they don’t match the running kernel, do an update and they then should. Should work.

1st do “lspci -v” in a terminal and make sure you actually have a AR5007EG wireless. If not the stock rpm in Yast should work just fine.

Thanks for that will try it now!

sorry i havent responded sooner, my ethernet was messed up

it works, after geting madwifi working as snakedrivers instructions (had to update the kernel) i eventually fiddled about (dont know how - just randomly changing settings!) and managed to iwlist scan for my network! then it took ages to actually get the settings right for my network (using a static ip made it really difficult for some reason!) but i managed to get there.

Thanks for all your help! lol! it really helped :\