keepassx

I’m trying KeePassX for the first time.

There are 2 icon buttons: copy-username-to-clipboard and copy-password-to-clipboard, they don’t seem to work.

I select an entry in the database which gets highlighted, click the copy-username-to-clipboard, click on a webpage username, then control-V and nothing gets copied.

What am I doing wrong?

Thank you.

Click on your clipboard in the systray. If an entry is there, you click once on the entry and then paste.

Are you able to paste the username into another application, e.g. an editor?

Which browser do you use and which desktop environment?

For me it works with firefox on KDE (my defaults).

Hendrik

I have a similar set up as you have. I like to use kate as my editor.
I’m also using Firefox 52.1.1 and my DE is Plasma 5.8.6.

Take a look at Qpass as a password generator.

I’m using KDE and Firefox.

The copies make it to the system tray, but not to Kwrite or Firefox, not with edit/paste or control-v.

Guess I don’t understand how to use the clipboard, or maybe I did something to defeat it.

Can you put something onto the clipboard and use it in another program, like a buffer?

BTW, is there a command to clear the entire clipboard?

I’m using the clipboard not explicitly, but through all possible key sequences (Strg-C / Strg-V, Strg-Ins / Shift-Ins, …).
Did you install keepassx from the official openSUSE repository for 42.2?
KeepassX has a feature of “clear clipboard after x seconds”. Please check this setting. Maybe you were not fast enough :wink:
Otherwise I’m running out of ideas.

Hendrik

FYI

Never highlight a section of text (using the left mouse button) before pasting your first selection as it clears your previous selection from memory.
That may work in Windows but not in Linux. However, the clipboard should have your previous selection in memory.

**Using the Clipboard
**

  • Left-click on the clipboard icon
  • Left-click once on the text that you want to copy from clipboard
  • Navigate to your editor and right-click and select paste, edit->paste or ctrl+v

=hendwolt;2823735]KeepassX has a feature of “clear clipboard after x seconds”. Please check this setting. Maybe you were not fast enough :wink:
Otherwise I’m running out of ideas.

Hendrik

Agreed. Disable the option to “clear clipboard after x seconds” if you haven’t mastered the clipboard.

Practice using your clipboard. It’s not that hard. :wink:

Editing Clipboard Options

When editing the options in clipboard, right-click on the clipboard icon. Navigate to Selection and Clipboard.
Select "synchronize contents of the clipboard and the selection". I find this more helpful when copying.
Click on the Apply or OK buttons. Use the “middle button” of the mouse for pasting.

There’s also a feature for creating a Global shortcut for clearing memory history.

Did you know?
For more help Plasma 5 provides a What’s This? help feature that shows help pop ups…
Right-click on the text of the option and click on What’s This?".
A big block appears with help about the option.

Great, making progress.

Romanator, thank you for the Using-the-clipboard tips.
especially right click on clipboard and “synchronize contents of the clipboard and the selection”.
I can now paste usernames and passwords directly into firefox.
Joy!

Hendwolt Did you install keepassx from the official openSUSE repository for 42.2?
I installed it from here https://software.opensuse.org/search

Good to hear that you worked that out. I ran into that problem with previous versions of KDE4.
Once you look at the options and experience the functions, you will always remember it in future versions.

In keepasx you might want to set the lock database to a higher number.

Add this Extra repository to Yast. You will find a lot of great applications.

http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_42.2/

Good Luck!