KDM login to KDE not working in 11.4


I’ve tried to google this problem but only find things similar but not really what I’m looking for so here it goes:

I have a newly installed openSUSE 11.4 (several reinstalls actually) which will not login to KDE (Plasma Desktop) from the KDM menu. When trying, the background image of KDM flickers a bit and I can see a hint of the bottom panel contours before it disappears again and only the KDM background image is shown.

I have the right click menu working and also I can see started applications when alt+tabbing as white squares on the screen but no plasma desktop appears. It’s as if the KDM background image blocks the desktop behind it.

If I switch to a console and init 3, log in as root and then run startx…the KDE Plasma Desktop loads and works brilliantly, but I cannot do this as a non root user.

Logging in to IceVM from KDM works as a normal user.

I figured this could be some kind of permissions issue so I tried creating a new user but I had no luck with that either.

Does someone have any tips on how to solve this problem or a way to troubleshoot it?

Does it work if you select failsafe mode for KDE?

No, the KDE failsafe mode gives same result as normal KDE mode with a quick flicker of the KDM background and then nothing more except “behind” the background image.
The other failsafe option displays a terminal but that’s not a KDE session I guess.

Right, that other “failsafe” is not KDE.

One of my systems was funky with KDE, until I turned of desktop effects. But if the failsafe KDE doesn’t work for you, then you probably have a different problem.

Is this a clean install? Or did you have a previous $HOME directory? If you had a previous $HOME, it could be the old configuration causing incompatibilities.


My $HOME has been tagging along through various distros for probably around 10 years or so…
For the previous new user I created, I only did a useradd and did not create a $HOME…so now I created another new user with a $HOME and this one can login fine. From here I should be able to figure out what breaks the login for my normal user and restore it to working order again.
Thank you very much for the pointers!

Am I able to mark this thread as solved or is that for moderators to do?

I’m glad to see the progress.

I have the same problem. It could be from the older 11.3 version (but I do not want to loose the data!), but the reason could be the display (graphic card) driver, I have found somewhere in a .log file a message to disable KMS in the kernel. I have a graphic card based on Radeon X1550. Another joke is that the driver of AMD for the Radeon boards is unable to run completely (it is probably for older Linux styles), so I cannot test a driver “from its mother”. I have tried too the console, init 3 way, but the success is only partially: akonady does not run correctly in Kontact and Thunderbild is unable to see the own address books. Another interesting point is that when I pass from 11.3 to 11.4 without marble, the screen does not become black immediatelly, it become black after the first restart. Another bad point is that I can not return quickly back to 11.3 because of the same akonadi, that does not run correctly unde 11.3 after the return from 11.4, so the return to 11.3 is possible only with the salvation of the data, meaning a lot of time. The global result is that I already lost 2 days, I am working very hardly with 11.4 (using alt+F2), and I have to save separately all the data from the computer begore to return to the excellent and surely 11.3. Another prove of the quote saying “The death of the well is the very well”.