KDM login settings grayed out. Can't change KDM theme.

I’m on openSUSE 11.1 KDE 4.3 RC, and I’m using the kde-branding-openSUSE with KDM from the factory KDE repo, and factory community repo - everything is up-to-date.

For some reason my KDM login settings screen is ALL grayed out, so I can’t change the theme/settings. I know that you can change it by going to yast and editing the /etc/sysconfig thing (which I actually tried doing, and failing, which is odd because I changed it once a long time ago to glassified, but can’t manage to do now…) I don’t want to use a theme, though, but actually use my current wallpaper and set the settings in the login manager to something of my preference. How do I go about doing this?

I just read the title, and I hope a mod can change that “KDL” to “KDM”

The reason is that it didn’t work. It is a BUG and to change the theme You need to use YaST for this. Just unpack the theme to /usr/share/kde4/apps/kdm/themes and then adjust it with YaST in sysconfig–>> Desktop -->> Display Manager -->>DISPLAYMANAGER_KDM_THEME.

P.S. Watch the theme’s folder name as it has to be the same including capital letters. Have phun
P.S.2 Just reread :wink: You adjust everything in YaST :slight_smile: What sort of settings you’d like to adjust?

I want to change the background image, but that’s about it… maybe mess with other things, though, I dunno, but I’ll be content with a background that’s the proper aspect ration (1280x1024, rather than the 1024x768 that “glassified” uses.) I tried editing things in yast, but for some reason the setting for KDM_THEME didn’t change anything (there were two, and I changed them both to say “Peace” without the quotes.)

Actually, I’m trying to install the KDM theme generator (Kdm theme generator KDE-Look.org) but can’t get that to work because I can’t find the kdelibs5-dev and build-essential packages – so I decided to do things manually, but here we are :frowning:

The recommended dependencies are for Ubuntu not openSUSE. Install kernel-source, make and gcc-c++ and kdebase4-workspace-devel. And you should be fine :slight_smile:

<3 !! Everything is working perfectly now, except the background doesn’t have my wallpaper, lol. That seems to be happening to a few people on kde-look.org, so I’ll see how they fixed it up. Thanks again!!

keep an eye over there been working with the developer on this program to get it working right even though i got it working on my end now

on opensuse 11.1 and 11.2 , with kde 4.x on 20/03/2010 still got problem, can’t change kdm theme from control panel or using yast

great !!! solution from novell will come soon ??>:(>:(>:(

I use:
Personal Settings/Configure Desktop -> Advanced -> Login Manager. There is a “Help” button at the bottom of this dialog.

There is some strangeness, but I was able to get it set.
I think some things are used/not used when disabled/enabled. I made sure everything was set the way I wanted and that required some disabling/enabling. I don’t know which options take precedence or if they work together - Login Manager or /etc/sysconfig Editor.

It can also be done like this:

Open a terminal window and do:

su -       (don't forget the dash, enter rootpassword)

This brings you in ‘Systemsettings’ with root permissions. You will see that you can choose, and install new themes now.

After a lot of test some themes ares working with yast and some others none.
circles work but not oxygene for exemple

my remark still on when Novell will solve this old problem and use normal way to change kdm theme from control panel instead yast