Kdevelop doesn't close

Hey I’m using kdevelop5 but when i close the program it doesn’t close. So when i want to open it again it won’t open because the process is still running. I have to kill -9 the kdevelop process to get it to close, the kill command by itself without -9 doesn’t even close the program. Just wanted to let you guys know, maybe there will be a fix for it if i post this.

Might be something to do with me deleting files in my home directory cause I just deleted all my home directory files and rebooted and now kdevelop works right.

Including the following directories? –

  • ‘~/.local/’
  • ‘~/.local/share/kdevelop/’
  • ‘~/.config/’ – only ‘~/.config/KDE/Sonnet.conf’ …
  • ‘~/.cache/’

Isn’t that implied by the word “all”?

Yes, but, I wanted to make clear that deleting everything also deletes the application’s settings and possibly some of the run-time temporary storage …

  • If the OP also had their KDevelop project in their home directory then, that got deleted as well as and also … :smiling_imp:

As he seems to be happy and states that the product works, I do not see why all the black scenarios (to try and make him nervous :wink: )

only thing i saved is a couple of things like .bashrc .vimrc my Desktop folder a couple of jar files i use occasionally. and my bin folder. oh and a folder called src that i put all my source code in. All my config files wer deleted and i think i caused the problem by deleting some config files, but deleting all of the config and stuff fixed it.

I take it back tho i don’t know why but its not closing again it worked for a short time but now its back to not closing when i close the program.

I only changed the default color of some integers and enable closing brackets in editing and look ahead code completion.