KDEInit could not launch...

openSUSE 13.1 KDE 64bit.

After updating Google Chrome does not run.

“KDEInit could not launch ‘/usr/bin/google-chrome-stable’.”

Help me!

I can confirm this behavior. Just updated and I’m getting the same error. Won’t even launch through a terminal.

Check the file maybe the name changed

‘usr/bin/google-chrome-stable’ no longer exists on my system.
There was no problem before the the last opensuse update.

look for just chrome*

I believe they may have renamed it.

Don’t use Chrome myself like to keep Google tracking down to minimum


My openSUSE works with KDE interface and I have the icon “google-chrome.desktop” in my desktop.

Go to “Desktop” with Dolphin, right click “google-chrome.desktop” and click to properties.
In the tab “app”(application) click in the Browse button and go to:


and add %U to the command line.

It will look like:
/opt/google/chrome/google-chrome %U
and click “OK”.

Now click in the icon “google-chrome.desktop”.

Google Chrome works fine.

Thanks for rhus’s solution. It works for me.

I have no Google-Chrome desktop icon on my desktop. So I right click the entry in Application Menu → Internet → Google Chrome, and select Edit Application …, then edit the Command line in the Application tab as rhus suggested.

Maybe it is the same to edit google-chrome.desktop file in /usr/share/applications/ and replace /usr/bin/google-chrome-stable with /opt/google/chrome/google-chrome in all 3 places. (need root privileges.)

hi, I have recreated a link /usr/bin/google-chrome-stable to /opt/google/chrome/google-chrome. The problem is that chrome has lost kwallet integration and I now get a dialog to create a new “keyring” when starting chrome. Anybody have a solution?

I received three times a dialog box to create a new “keyring” when starting chrome.

The problem was only solved when I did it.

Start Menu -> Application… click with the right button -> Edit Application.
Internet -> Browse Web -> Google Chrome…, then edit the “Command”.

Place the following:

/opt/google/chrome/google-chrome %U 

Save and close the application.
I did not have more problems with “keyring”.

Hi there!
I have the same problem: KDE wallet is disabled, so Chrome ask for “Enter password for keyring ‘Default’ to unlock”. If I provide a password, Chrome doesn’t ask again until I restart openSuse. If I don’t provide the password, I can use Chrome normally, but Chrome ask for the password the next time I open a new Chrome session.
Then, I applied the rhus solution by editing the command.
But when I restarted openSuse, the “keyring” dialog, appears again.