KDE4.6.3 messed up after last upgrade

I installed latest updates for KDE and Nvidia.

OpenSUSE 11.3 64bits:
-> KDE4.6.3 “Release 4” and Nvidia Quadro NV140:Nvidia 270.41.06

This is a Dell Latitude D830 laptop docked in D-dock with external monitor(TwinView).
External screen is defined as Primary.

Now after upgrading and reboot KDE is messed up. My whole desktop is “moved” over to internal secondary screen, but taskbar(panel) is remaining on the external screen. I moved all desktop-objects back to primary external screen, but the taskbar(panel) is some how dead. Its there, but completely invisible. I can’t click(right/left) on it and can’t remove it. Its there since all maximized windows is limited to where the panel is. I had to add new panel to get the start-menu back, but this is automatic located at the top of the screen.

I’ve tried to reconfigure Nvidia to singe screen and back to Twinview, but the problem remains. Can this be some sort of a new bug? How can i fix this?
I want to remove the dead panel and replace it with a new one that works.

Have you tried moving away your ~/.kde4 folder and let it recreate your .kde4 folder? Be warned though you will loose your settings if you do this.

Thanx! i got it back now!

My only small problem now it that the “Folder view” don’t show my Desktop shortcuts. I choose to show Desktop, but it shows the files in Home-folder. If i select manual folder and point it to /Desktop, then it shows the shortcuts with file-name; firefox.desktop etc…

Is this i bug or do i something wrong?

move mouse to right hand edge -> click on ‘spanar’ icon -> Choose Specify a folder -> choose the folder of your choice.