KDE4.1.2 update tonight; Firefox & Cairo-Dock won't start

Firefox will not start.

If I run firefox in a terminal I get the following error and firefox fails to start. Opera runs fine. This is KDE4.1.2 which I updated tonight.

XXXXX@linux-vd0b:~> firefox

(firefox:4883): GLib-GObject-WARNING **: Two different plugins tried to register ‘QtEngineRcStyle’.

(firefox:4883): GLib-GObject-WARNING **: Two different plugins tried to register ‘QtEngineStyle’.

(firefox:4883): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)’ failed
/usr/bin/firefox: line 126: 4883 Segmentation fault $MOZ_PROGRAM “$@”

Anyone have any idea what is causing this?

Couple of other things I’ve noticed about KDE4.1.2

  1. The volume and the openSUSE updater icons in systray are distored - that is you can only see part of them, and the icons for kpowersave and knetworkmanager never change with the theme. They always display a generic icon which looks like a sheet of paper.

  2. If I press and hold the spacebar or the backspace key the cursor will only move one space. How do I change the repeat stroke setting in KDE?

I am using KWIN with compositing enabled.

None of these problems appear in Gnome.

Thanks in advance for any help.

Sorry I can’t be of more help.

How do I remove a plugin from FF if I cannot start the program? Is there a way to start FF without any plugins or addons??

Is there a ~/.firefox file that I can delete and start over?

With the spacebar and backspace I am talking about repeating keystrokes. Normally if you hold down the spacebar it keeps moving until you release it. To move more than one space I have to press and release, press and release, etc. Don’t know how to make it any clearer.

in your hidden ./home/username/mozilla/firefox

delete the firefox folder. but you might want to collect your bookmarks file if you don’t have it in another browser

What about Cairo-Dock? Do the same thing?

I think it has to do with updating Qt from two different repos. I must have two different versions running or the same version running twice. (awhile back I updated from Qt44 and more recently from Qt to fix a couple of dependency errors.)

Where is the bookmarks folder? I tried to import them into Opera (which words by the way) but only got part of them. ~/.mozilla/firefox/<filename>/bookmarks.html

That is all I could find.

Okay, deleting the firefox folder under .mozilla in my home folder didn’t help. I get the same error. Should I delete the entire hidden folder ~/.mozilla ??

I installed Seamonkey, but it will not start either – I guess it uses the same extensions.

I don’t know what to do. Any ideas?? Anyone?

I’ve now uninstalled FF3, Thunderbird and Cairo and deleted their configuration files ~/.mozilla, ~/.thunderbird and ~/.cairo-dock.

The problem is the plugins are not there. They are in a separate folder called “browser-plugins.” If I delete that one it will screw up my flash, java, etc.

Reading the segfault message again, it is obvious what the problem is because it says so right there. But what two plugins are trying to start separate instances of those qt libraries?

Doesn’t seem to me that reinstalling FF and Cairo-Dock or Thunderbird will help either because they will look to the same plugin folder. I guess I could delete some files from browser plugins I don’t need.

I do know I have Flash 9.0 and 10.0 RC2 so I am wondering if I could delete either libflashplayer.so or swfpdec.so or somehown uninstall the older version.

I feel like I’m talking to myself, but if anyone comes on here is there a way to start FF3 in safe mode? I tried firefox -safe-mode (found that on a google search) but it didn’t help. Still got the same error.

Well… I was hoping to catch you before you went this far…

Whenever you have a plugin issue such as this that either doesn’t allow firefox/thunderbird/sunbird etc to start or it starts and then crashes, first think about the last thing or things you did. Did you recently try a new theme? Sometimes themes are not compatible making firefox unstable or crash to the point of not starting. Did you recently install a plugin? That could also be incompatible…remember…plugins for the most part, are called extensions in firefox, mozilla applications. In your .mozilla/firefox folder you will find a folder with a odd name this is your profile folder. In it you will find a folder called extensions. There you will find all the folders of the added on extensions that you have installed.

Remember, this is the firefox folder not just the .mozilla folder because that has an extensions folder as well…leave .mozilla/extensions alone…you want .mozilla/firefox/profile folder

Here is what I did to test out extensions aka plugins that did not work…first outside of the extensions folder, maybe even outside of the firefox folder, create a new folder called old extensions copy all your contents of extentions in here.

Do This with firefox closed (or not running for those testing theirs)

Next restart firefox.

You should see firefox start with the default skin (theme) and none of your extensions…

If you still experience problems then what I would do is to rename your profile folder to something like profile old and then

Restart Firefox. This should take you back to all the defaults and zero start. This will mean you will need to reset everything and from here you can begin migrating things from profile old to new profile. When you are set-up then delete the old folder or move it out of the mozilla folder and put it in like a back up somewhere…who knows…maybe you will need it later…If you can get your bookmarks loaded from the old bookmark folder, I would highly recommend exporting your bookmarks.

There you go, if this happens again, give this a shot…

OK so now I read that after deleting you didn’t infact get it to work…now I am puzzled…I would go under the /usr/lib folder and find the firefox folder there and rename the extensions folder to old extensions and retry. You might try forcing an update of all mozilla components in YaST and if that doesnt work try uninstalling all the mozilla components and then shutdown/reboot and try YaST to reinstall all the components.

Give that a shot and see where it gets you


The above is good advice. Always backup folders you plan to delete or even easier is to re-name it OLD.
Creating a new user account can sometimes help determine if you have a system wide issue, you can always delete the account later.

Thanks for trying to help. This one has me stumped.

How do I do that in KDE4.1.2? (create a new user?)

Why is it there is NO problem in Gnome?

If you have no problem in gnome, then it must be related to some kde settings.

You said everything was basically screwed after you deleted some files? Is this still the case?

Just tell us the difference NOW between the two desktop environments.

We can always try rename ~/.kde4 to .kde4old

and this will start a totally new kde4 setup

I’m a bit confused here. Right now, my system stands this way. I have uninstalled all mozilla, thunderbird, FF apps and have deleted all the ~/.<filename> folders.

I still have Opera installed which works in KDE. (sorta) Epiphany works in Gnome. Sorta)

I backed up my bookmarks before I did this.

Now I still have /usr/library/browser-plugins.

You’ve got two suggestions here. I can’t really create a new user because I’ve deleted all the apps. I guess I could try that after I’ve reinstalled though.

Should I change the name of the browser-plugins folder to something else and reinstall all the mozilla stuff in Yast? What about java and flash?

Should I just try forcing a reinstall of all the mozilla stuff including the plugins and not change the name.

The only thing I did was run a one-click install of Flash 10.0 RC1. I wasn’t getting any sound from embedded videos and that seemed to fix it, but now I’m wondering if qt is trying to call both Flash 9 and Flash 10 ?? They seem to coexist in Gnome okay.

You can use YaST to create a test user or from CLI;

su -
useradd -d /home/testuser -m -g users testuser
passwd testuser

Once you have finished you can remove via YaST or the CLI;

su -
userdel -r testuser

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 17:04, 2 users, load average: 0.02, 0.10, 0.18
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

I think I would create the new user first.

You haven’t deleted anything outside the desktop/user side have you? I mean in /usr/…

Did you keep a copy of your important data from the likes of Thunderbird? It has all your mail in it.

Re-install FF etc… but keep it to the basics. No flashy plugins or addons at first.

No, I have not deleted anything in /usr/lib. I just moved the folder “browser-plugins” to a temp. location and reinstalled FF. I previously deleted ~/.mozilla/firefox. Yes, I backed up everything critical. No mail in Thunderbird that I needed to keep.

After reinstalling FF3 I get the same error. I think it is a kde setup problem, but I can’t think of anything I did other than an update to KDE4.1.2 and a Flashplayer update.

Okay, so where do I go from here? Create a new user or delete ~/.kde ??

I think I’ll create a new user first. I can’t do any damage that way.

try one or both

re-name .kde4 to .kde4old will give a totally new kde4

Okay, what did I do wrong?

peyre@linux-vd0b:~> su
linux-vd0b:/home/peyre # useradd -d /home/testuser -m -g users testuser
linux-vd0b:/home/peyre # passwd testuser
Changing password for testuser.
New Password:
Bad password: it is based on a dictionary word
Reenter New Password:
Passwords do not match.
New Password:
Bad password: it is based on a dictionary word
Reenter New Password:
Passwords do not match.
New Password:
Bad password: too short
Reenter New Password:
Passwords do not match.
passwd: Have exhausted maximum number of retries for service
linux-vd0b:/home/peyre # userdel -r testuser
no crontab for testuser
linux-vd0b:/home/peyre #

Just create a new user in the Yast users section

Okay, did that and logged back in and FF works. Also, some other stuff that didn’t work before now works. Like the systray icons look correct now. Clock is different too. All in all the desktop looks better.

So what does this mean? Was my user profile corrupted somehow?

Where do I go from here? Can I create a new user (permanent) and just delete my old one and the temporary one?

What if I log back in under my old user and delete .kde? Any reason to do that now that everything is working? I mean it seems simpler just to create a new permanent user and delete the old ones. Everything is still there because my /home is on a different partition. Won’t I still be able to access it?