KDE wont boot from 11.1 live CD

How do I start KDE from the command line
Downloaded openSUSE 11.1 KDE 4 32-bit Live CD iso and md5. Checksum OK.
Burned CD. Verified burn, OK. Booted CD, chose openSUSE live option.
Everything seemed to load normaly, no errors. Instead of continuing onto the desktop,
it stoped at a login prompt. Typed root, got a bash prompt, and a message wishing me a lot of fun.
Tried failsafe option, same result.

Its likely the opensource (openGL) graphic driver did not work for your hardware. You could try the VESA driver.

Next time it stops as the login prompt, log in as a regular user (or has your regular user account been set up yet ? ). After you are logged in, type “su” (no quotes) to get root password. Then backup your /etc/X11/xorg.conf file with:
cp /etc/X11/Xorg.conf /etc/X11/xorg.conf.bak
… note linux is case sensitive.

Then type “sax2 -p” (no quotes) to see what graphic device, and what chip your graphics are using. Assuming chip 0 , then type:

sax2 -r -m 0=vesa #that is zero equals vesa

that should hopefully configure your pc with a low res vesa driver. When it is finished exit sax2. Then type “exit” (no quotes) to exit root permissions. Type “whoami” (no quotes) to confirm you are no longer root. Then type “exit” again if still root. Once you are no longer root type:


to test your X window. If that works, open a gnome-terminal or kde konsole (looks like a dos window) and type:

su -c ‘shutdown -r now’ #to reboot your PC (enter root password when prompted) and test if the video setting holds.

Good luck.

I just got a HP lightscribe usb cr/dvd drive that I burned the kde4 live cd with
on boot the kernel but the system loading balked so I tried my onboard dvd/cd drive and that worked. I am writing this with the live cd.

  1. at prompt login as root
  2. enter #init 1
  3. wait for a few seconds
  4. enter #init 5

you will be loged into liveKDE session

Thanks oldcpu. Doesn’t this release include
x-org 7.4? Other live distros that did, booted up fine into my native res ( 1680 X 1050 ).
I’m wanting to run strictly live for now, so
unless SUSE saves my .conf changes PUPPY style, that wont work.

I now see nikotron has a suggestion
I,ll try that.
Thanks to you to nikotron.