KDE Wireguard SurfShark

After much playing around with key pairs I developed this process for SurfShark that I hope might help others too … after creating a SurfShark account, this SurfShark and Plasma Applet process needs to be completed in full for each VPN end Location that you might like to use:

  1. Go to SurfShark Website https://my.surfshark.com/home/dashboard
  2. VPN / Manual Setup
  3. Desktop or Mobile / Wireguard
  4. “I don’t have a keypair”
  5. In Credentials … Name … eg WgSsLosAngeles (you enter a unique name for your key pair that will be registered in your “My Key Pairs” in SurfShark)
  6. In Credentials … “I don’t have a key pair”
  7. In Credentials … “Generate a new key pair”
  8. In Credentials … “Choose a Location”
  9. In Locations … “Los Angeles” … click download icon (choose your own preferred location)
  10. In Download configuration files … Download … click download icon
  11. In your computer’s Downloads files … change the name of the downloaded file (eg us-lax.prod.surfshark.com.conf) to a short name of less than 15 characters such (eg SharkLax.conf)
  12. On your computer’s desktop … right click Plasma Applet in tray / Networks / Configure Network Connections
  13. In Connections - System Settings … at bottom of left-hand menu click “+”
  14. In Choose a Connection … at bottom of menu … “Import VPN Connection” … Create
  15. In your computer’s Downloads folder choose the short name (eg SharkLax.conf)
  16. Authorise
  17. In Plasma Applet in tray / click Networks / Choose the new VPN (eg SharkLax) / Connect
  18. In SurfShark Website Home / Dashboard … observe the status “Protected”
1 Like

Some additional notes:

  1. Packages installed are only wireguard and wireguard-tools (not NetworkManager-wireguard or wireguard-kmp-default or anything else).
  2. To automatically start the vpn:
    i. Right-click Network Applet / Configure Network Connections
    ii. In Connections - Systems Settings select the Wireguard VPN (at the bottom of the left-hand menu) and authorise.
    iii. In General Configuration “Connect automatically with priority” click on and set priority to low … use say 9.

Try as I may, under KDE importing SurfShark config files never works, under Gnome there are no problems.
I tried with OpenVPN and Wireguard files. Can you impart some knowledge, oh Wise One? Please, I don’t want to give up KDE and I have 2+ years of SurfShark VPN left to use.