kde w/ dual monitor and quick launch

openSUSE Tumbleweed 20190917 (x86_64) on kernel 5.2.14-1-default
KDE 5.61.0 Plasma 5.16.5
I have a dual monitor setup with KDE, the quick launch on each taskbar is reversed, by that i mean that its on the wrong task bar. Opening anything on either quicklaunch opens on the opposite screen. Things minimize correctly to the correct taskbar but the quick launch items always open to the opposite screen. Also, the main menu items on my right screen always open on the left screen but the left main menu opens correctly on the left screen. And finally the left screen main menu icon is black&white the right screen main menu icon is green and white, not sure why that is either.
Is there a file somewhere i can edit to fix this? I really do not want to delete them and start over as its a real bear to configure these things.
Thanks in advance.

Do you have the correct position and primary display selected in systemsettings>Display & Monitor (or something similar, I’m translating from pt_BR)?

If you do, consider posting a screen capture of both displays, your description is a bit unclear.

Ok, let me try again.
Lets just take an example. The qucklaunch has icons to start programs, you load it with whatever program icons you like. When i click on any of the icons on the right screen’s quicklaunch they open on the left screen, they should open on the right screen because the quicklaunch is on the taskbar on the right hand screen(monitor). The same is true of the left-hand quicklaunch its on the left-hand monitors taskbar but its programs open on the right-hand monitor. Once a task is open it minimizes to the correct task bar so its not a matter of the task bars being swapped between monitors.
Thanks - HTH’s

I agree with the direction brunomcl is pointing, confusion on Plasma’s part which display is primary. Try running xrandr --output <intended-primary> --primary in Konsole. If it helps, put it in a startup script to see if it works that way too. If it does, there may be corruption in KDE/Plasma settings in ~/.config/ somewhere, or in KDE/Plasma’s ~/.cache/ files, or a Plasma bug.

the file that may help is

Another thing are you trying to unify your screens or have 2 different ones?

I don’t have a file in .local/share called screen (should I?)
I’m running two monitors, each has its own taskbar. Its not a unified screen.
xrandr shows the right screen is the primary (as expected) as does system->settings->display-and-monitor
I’m wondering - it might be useful to just delete the cache from run level 3 and then reboot.
Is it safe to just delete ~/.cache entirely? Well, i can at least move it to cache.old and then if its a mes just restore it
I’ll try that tonight, I have stuff running (my own stock market program) that i don’t like to interrupt during the day
Thanks for the help guys - its appreciated - I think we can figure this out, I’m feeling like it might be a cache issue - we’ll see.

Mmm, can’t test since I don’t have a second monitor, but …
Launch an app, then right click in the window decoration and see if there’s an option to set it to always appear on f.e. the right hand screen.

Oh, and BTW, it’s not ~/.local/share/screen, it’s** ~/.local/share/kscreen/**

My bad, yeh the kscreen directory is there. It has 3 files describing the monitor/screen/resolution/position setup. I reviewed those and they are correct.

I got fed up and reconfigured things from scratch - everything seems to be working now
Thanks again for the help guys!