KDE & startx login failure

After upgrading several packages (can’t remember which now) I can’t login with the graphical login. It accepts the password, starts to load, but then dies and dumps me back at the login prompt again.

Attempting to login from the prompt, sometimes works (there is specific condition), and when it does, I then attempt to “startx”. OK, it complains the display is already in use, so I then “startx – :1”. Everything starts to load, but then fails again like the graphical login.

checking /var/log/Xorg.1.log I see no errors [EE].

checking /home/***/.xsession-errors I see the following.

xauth: file /home/***/.serverauth.15914 does not exist

I have also tried as another forum suggested and rename the .kde4 and the .skel directories to something else. Login via graphical and prompt still both fail.

I have also tried logging in with another window manger. That also fails.

However, I have also tried creating a new user and logging in. That works. It is from this user account that I write the post.

I have attempted copying over all of the application settings from the corrupted user account, but some things are missing and there are various personal project directories and permissions that are causing issues. Therefore I would like to repair the corrupted account.

Where do I begin to fix the corrupted account?

OS: Linux 3.0.1-40-desktop i686
System: openSUSE 11.4 (i586)
KDE: 4.6.5 (4.6.5) “release 4”
Video: nouveau

See message #6 at the following concerning using startx:

Cannot startx unless Superuser

Thank You,

thank you very much @jdmcdaniel3 that forum thread looks quite useful and informative. 8)
I’m going back to read it very thoroughly.

thank you very much @jdmcdaniel3 that forum thread looks quite useful and informative. 8)
I’m going back to read it very thoroughly.

You are welcome leoplaw. If this does not prove to be the solution that you seek, please come back and let us know.

Thank You,

Unfortunately none of that from the other thread (Cannot startx unless Superuser) helped. In fact, I have now trashed the second user account I created and it now exhibits the same problem.

So what I did was

login to root
move both /var/log/Xorg.0.log and /var/log/Xorg.0.log.old to another name.
vi /var/log.0.log and created a new file.

login as user
move .Xauthority to another name
vi .Xauthority and created a new file.

startx fails as does reboot and login.

I also tried uncommenting the last line in /etc/permissions.local

startx fails as does reboot and login.

My /tmp directory has the following permissions. #1777

So what next do I try?

Have you checked that login session is: kde-plasma-workspace

And have you tried IceWM?

Or don’t you even have a UI login?

Hi caf4926. Yes, I have checked that the session is: kde-plasma-workspace, and I have also tried IceWM, I have also tried openbox window manager. All fail. If I create a new user, I can login normally. However I need to rescue the old user.

Yes, I have a UI login. This is all described at the start of this thread. From login, enter username & pass, starts to load and then drops me back at the login.

However, I can startx from the command line when logged in as root and using KDE. Hence how I am currently connected to the internet and writing this reply.

An idea:
Can you backup all your files to somewhere (windows partition? other space)
Create a new user and login with it
Delete your normal user, including the /home files
Now re-create the user you just deleted.
logout and login with your new normal user, test it. if it’s OK move the files back

(p.s) you may want to backup some hidden files/folders, but I would keep it to a minimum
important stuff like .mozilla .thunderbird
Backup .kde but don’t reuse it ! You could get some of your app settings if you really need them though

I already kind of did something like that, by creating user #2, copying over files and dirs from the broken one, and then only specific directories and files from .kde4, however certain things such as MySQL database connections weren’t working properly. I have no idea if that was because the user name was different. I added user #2 to the same groups, but still no joy. Things like Digikam could not connect to the MySQL database. So I was hoping rescue the original user, because everything just worked.

ok I’ve finally gone for back up data, delete old user, recreate the same user, and then copy over various configuration files being careful not copy over all of the kde config files.

I now have to sort out configuration issues for various applications.

I always keep a copy of .kde4 and can fetch from there the really important stuff. For me that is: konversation, korganizer.
Outside of that it’s just: .mozilla, .thunderbird
I never bother with all the look and feel. The less you bring in the better, especially in a case where you are trying to resolve issues like yours.