KDE Shutdown timer.

Google search reviled another user asked this question in the forums but the answer wasn’t really satisfying.

When I click the shutdown button in the start menu I get a shutdown timer of 60 sec or the choice to suspend or hybernate. I want to simply shut down, not wait a full min then shut down. How do I get rid of this timer. (this is a laptop I really don’t need to warn other users that they system is going down as there is only one user)

Opensuse 12.3 64 KDE on hp pavillion g6 laptop.

This is a system for my 68 year old mother so please don’t say hit ctrl-alt-etc etc etc while doing the hoky pokey or drop to a prompt and run shell script etc. if it takes more than two clicks to shut down the OS will not be accepted by her. (and two clicks is pushing it!)

60s? For me it is 30s…

But anyway, the option you are looking for is “Configure Desktop” (aka. systemsettings)->“Startup and Shutdown”->“Session Management”->“Confirm logout”.

When you are presented with the Shutdown dialog, there should be a small downward-pointing triangle just to the left of the Shutdown button. If you click this, your system should go straight to shutdown.

At least mine does…

Trollicus wrote:
>
> Google search reviled another user asked this question in the forums but
> the answer wasn’t really satisfying.
>
> When I click the shutdown button in the start menu I get a shutdown
> timer of 60 sec or the choice to suspend or hybernate. I want to simply
> shut down, not wait a full min then shut down. How do I get rid of this
> timer. (this is a laptop I really don’t need to warn other users that
> they system is going down as there is only one user)
>
>
>
>
> Opensuse 12.3 64 KDE on hp pavillion g6 laptop.
>
> This is a system for my 68 year old mother so please don’t say hit
> ctrl-alt-etc etc etc while doing the hoky pokey or drop to a prompt and
> run shell script etc. if it takes more than two clicks to shut down the
> OS will not be accepted by her. (and two clicks is pushing it!)
>
>
This behaviour of confirming whether a user really wants to shutdown
is common across many OSes like MS,MAC,Linux etc…


GNOME 3.6.2
openSUSE Release 12.3 (Dartmouth) 64-bit
Kernel Linux 3.7.10-1.16-desktop

On 07/18/2013 09:36 PM, Trollicus wrote:
> if it takes more than two clicks to shut down the
> OS will not be accepted by her. (and two clicks is pushing it!)

lots of ways to skin cats (the easiest is in the last line):

you could (at least in my KDE…which is not the same as yours) go
Configure Desktop > System Administration > Startup and Shutdown >
Session Management > General and uncheck “Confirm logout” and “Offer
shutdown options” and see if that presentation would make her happy…

or, you could place a clickable link in a place easy for her to find
(but not accidentally click), to a bash script with the proper
shutdown command (shutdown -h now) then change the shutdown
permission from (default) root only to any user (via YaST > Security
and Users > Security Center and Hardening > Boot Settings > and
change “Shutdown Behavior of KDM Login Manager” to “All users”) and
then her one click would cause a controlled/normal system shut and
power down…

there are probably several other things that would make her happy, i
can think of a couple immediately…like, 1) reduce the wait from 60
to 6 seconds (or one second–but, offhand i don’t remember where that
number is stored), or 2) when that prompt with options and 60 second
timer comes up, just click the shutdown icon and it (should)
immediately shutdown, no waiting required (but that is two clicks).


dd
http://tinyurl.com/DD-Caveat

I had some problems finding it, but found it.

I click the wrench and screwdriver symbol. ( system setting ? ) then start up and shut down.

Then again the symbol with the wrench and screwdriver, and at the top of the next screen, there are two options. rotfl!

Unchecking the first one did the trick.