KDE Plasma software update applet throwing an error (couldn't resolve proxy: HTTP_PROXY)


I am trying to launch an update applet and make it search for the new updates. However instead I get:

Download (curl) error for ‘http://download.opensuse.org/tumbleweed/repo/non-oss/repodata/repomd.xml’:
Error code: Connection failed

Error message: Could not resolve proxy: HTTP_PROXY

I did zypper dup in terminal, which worked flawlessly.

I tried:

  1. Setting global proxy to none (in the KDE), then rebooting.
  2. Removing .config/plasma-pk-updates, then restarting Plasma shell.
  3. Googling a little.

None of these helped.
I still hope this to be a temporary error, as on my laptop everything works fine.
What can be wrong this time?

It gets deep even further to the PackageKit:

~> pkcon -v update
06:53:25 PackageKit Verbose debugging enabled (on console 1)
06:53:25 PackageKit filter=(null), filters=0
06:53:25 PackageKit adding state 0x562c42efcbe0
06:53:25 PackageKit role now get-updates
Getting updates =========================]
Finished ] (0%)
06:53:25 PackageKit remove state 0x562c42efcbe0
Command failed: Download (curl) error for ‘http://download.opensuse.org/tumbleweed/repo/non-oss/repodata/repomd.xml’:
Error code: Connection failed
Error message: Could not resolve proxy: HTTP_PROXY

But my $HTTP_PROXY variable is empty?!

Do not take this advice to serious, but you could remove the applet and just use zypper.

But, when you like it, maybe someone who uses it will come to your help here. :wink:

Sure I can do that, but the problem lies even deeper — in the PackageKit, or curl. Whom should I ask what to do now?
And I’ll say again, I have both desktop PC and a laptop and this problem happens only on the former.

Is there a way to reset PackageKit settings?

I just tried to enter superuser shell with sudo -i and run pkcon -v update. And it worked!
So, the problem is somewhere in my profile settings.
Any ideas?

I also created test user in YaST, logged into it, and there is no problems neither with KDE Software Updates or PackageKit.
What is going on?

Edit: everything started to work and I don’t even how. :question:

Please wait for others and not for me. I haven’t PackageKit installed, nor the applet.

The only thing I can say that when it is bound to that user, then try to find within that user’s .config and/or .kde4 directories if there is a place for the Applet (I forgot it’s real name). And then remove that.

I don’t know. I would guess that either it is in your shell startup script (usually “.bashrc”) or in your desktop settings. If you are using KDE, then under System Settings, look for Network Settings, and check the Proxy setting there. Here, I have it set for “No Proxy”.

Edit: everything started to work and I don’t even how. :question:

Maybe you fixed it. That’s good to hear.

By the way, I removed the “test” user, rebooted the PC and stopped working. [Now I removed .config/plasma-pk-updates and moved .kde4 to .kde4.bak, and voila, it works.]]] It doesn’t. I rebooted and it stopped working again.

I am sure not lucky today.

In the past I had an proxy autoconfiguration file set there, but not anymore. Still doesn’t change anything.

No, unfortunately.

Another strange thing noticed.
When I log out and log in, everything works (pkcon, Plasma applet); but when I reboot and log in for the first time, they throw me an error (that “curl couldn’t resolve proxy: HTTP_PROXY”).
What is this sorcery?

Check the file “/etc/sysconfig/proxy”.

I don’t see anything unusual, do you?

Path: Network/Proxy


Type: yesno

Default: no

Config: kde,profiles

Enable a generation of the proxy settings to the profile.

This setting allows to turn the proxy on and off while

preserving the particular proxy setup.


Type: string

Default: “”

Some programs (e.g. lynx, arena and wget) support proxies, if set in

the environment.

Example: HTTP_PROXY=“http://proxy.provider.de:3128/


Type: string

Default: “”

Some programs (e.g. lynx, arena and wget) support proxies, if set in

the environment.

This setting is for https connections


Type: string

Default: “”

Example: FTP_PROXY=“http://proxy.provider.de:3128/


Type: string

Default: “”

Example: GOPHER_PROXY=“http://proxy.provider.de:3128/


Type: string

Default: “”

Example: SOCKS_PROXY=“socks://proxy.example.com:8080”


Type: string

Default: “”

Example: SOCKS5_SERVER=“office-proxy.example.com:8881


Type: string(localhost)

Default: localhost

Example: NO_PROXY=“www.me.de,.do.main,localhost”


If anything, it’s the same as on a laptop, I just checked.

That looks clean. So I’m not sure where the problem comes from.

Does your DHCP server (probably your network router) try to give any proxy configuration?

I connect to my ISP directly via Ethernet cable via IPoE, so maybe. How do I check if there is something extra my ISP tries to push to me using DHCP?

I ran *dhcpdump *and found nothing except some “Vendor specific info”:

OPTION:  43 ( 40) Vendor specific info      0126687474703a2f .&http:/
                                            2f31302e3139322e /10.192.
                                            3234312e3234392f 241.249/
                                            74723036392f7365 tr069/se
                                            727665722e706870 rver.php 

What bothers me more is that everything starts to work when I log out and log in into KDE again, but after reboot and first log in (I don’t do it automatically) it refuses to even check updates.

Maybe its a bug.

At some time in the past, I use the KDE update icon. I always did updates from root command line. But by enabling the update applet, I could look at the tray. If the update applet reported updates, then it had already refreshed the repos. It the update applet was still showing but not indicating updates, then it was busy refreshing. So I would wait.

But, at some time, that stopped working. The update applet never showed in the tray. If I looked at the hidden tray, the applet said there was a network problem. So perhaps that was the same problem.

Recently, I have been doing a first login to “icewm” to update, and then a later login to KDE. So I haven’t been seeing this. But I’ll go back to the previous ways and see if I can monitor what is happening.

If it’s a bug, then I don’t know where to report it and how to report it. Since looks like I am the only suffering I doubt it would be easy to reproduce and take measures against.

I can only summarize:

  1. Launching sudo -i and then pkcon -v update or just doing sudo pkcon -v update works, but doing it as the main user doesn’t work. (i.e. without sudo)
  2. Both pkcon and applet complains they couldn’t resolve proxy (perhaps through curl) HTTP_PROXY, which I haven’t even set.
  3. Logging out and logging in back solves the problem. Rebooting and logging in for the first time brings error back.

Then I think I am seeing something a bit different.

After boot and login, if I hold mouse of the update applet in the hidden tray, I see: “Checking for updates failed”

However, if I use (at a terminal)

pkcon refresh

that works. And, after that, the applet also works.

If I logout and then login again, this repeats.