KDE/Plasma login issue

Leap 15.4


I’ve regularly a small issue with login screen, simply not shown on splash (?) screen.
Not 100% reproducible, very frequently triggered by inactivity at startup (Booting machine in into graphical.target, login, fine. Booting machine in into graphical.target, do nothing for a period x, no login screen shown (anymore).
Very frequently also triggered by a logout, not login screen, just splash screen after logout.

My workaround is to use a virtual console (ctrl-alt-f1-6) and a “systemctl isolate multi-user.target && systemctl isolate graphical.target”. (Remark, IMHO funny: wasn’t sure if “multi-user.target” is correct with a dash or not, so switched to my virtual console to look up last command. “Destroyed” my session, wasn’t able to get back to Plasma via ctrl-alt-f7, still shows last login screen state after entering password…, had to systemctl … again)
Known issue? Bug, to be reported?

Thanks in advance,

I have not experienced this, so I probably can’t help. However, you omitted one detail. Are you using SDDM for the login screen, or are you using something else?

Here, I am currently using GDM.

Because, the Display Manager – in the case of KDE Plasma, SDDM – has power saving as a feature.

  • Which, AFAICS, cannot be disabled …

Solution: move the Mouse – slowly …

  • However, if you have a large screen, with lots of densely packed pixels, it often takes some time before the screen wakes up – which is also an issue for these devices on other operating systems …

In my case, this hardware – Iiyama PL3288UH 32 inch, 140 DPI, 3840x2160 pixels, screen:

 > inxi --admin --filter --graphics
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: HDMI-A-1 empty: DP-1 bus-ID: 06:00.0 chip-ID: 1002:15d8
    class-ID: 0300 temp: 38.0 C
  Display: x11 server: X.Org v: 1.20.3 with: Xwayland v: 21.1.4
    compositor: kwin_x11 driver: X: loaded: amdgpu dri: radeonsi gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 140 s-size: 698x393mm (27.48x15.47")
    s-diag: 801mm (31.54")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Idek Iiyama PL3288UH
    serial: <filter> built: 2020 res: 3840x2160 hz: 60 dpi: 140 gamma: 1.2
    size: 698x393mm (27.48x15.47") diag: 801mm (31.5") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  API: OpenGL v: 4.6 Mesa 21.2.4 renderer: AMD Radeon Vega 11 Graphics
    (RAVEN DRM 3.42.0 5.14.21-150400.24.46-default LLVM 11.0.1)
    direct render: Yes

What does the following report?

xset q


Assuming that, you’re not using Wayland and, that you’re using X11, please provide the output of –

> cat /var/log/Xorg.0.log | grep 'DPMS'

Hi all, many answers, thanks !!

@nrickert: as @dcurtisfra correctly said: KDE/Plasma, that’s why SDDM, as default.

@dcurtisfra: As I wrote in line 3 in my first post, I’m using Wayland. Mostly, as I had very weird issues with X11, probably because of my Intel graphics card… different topic, probably forever unsolved.

I’ll try your hint reg. “slowly moving the mouse” next time, as fast moves and typing doesn’t help.


$ xset q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  600    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
  default colormap:  0x3f    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
DPMS (Energy Star):
  Server does not have the DPMS Extension
Font cache:
  Server does not have the FontCache Extension

Hmmm…The xset command ran with Xwayland, while SDDM appears to use full X-server (running in tty7), so the output may not be applicable. Pure speculation, but I wonder if a minimal /etc/X11/xorg.conf might be sufficient here?

Section "ServerFlags"
    Option "BlankTime" "0"