KDE Plasma lock screen not showing user

I searched about this topic but couldn’t find anything.
When the screen is locked in a KDE session the name of the user is not shown in the lock screen.
I’d like to have it shown. For example, I have a Arch Linux Plasma 5 installation and there, when the screen is locked, the user name is shown.
I couldn’t work out where to change this.
Anyone has a hint?

Thanks in advance

System Settings > Startup and Shutdown >Login Screen
Choose an appropriate theme, e.g. Breeze for openSUSE.
If already selected, choose and apply another theme, then change back.

The name shows up for me. That’s the full name, not the login userid. And the lock screen looks like the SDDM login screen. So I think eng-int is probably right that it depends on the login screen theme. Set that with

Configure Desktop –> Startup and Shutdown –> Login Screen (SDDM)

My system is using the default (Breeze for openSUSE).

Hi. Thanks to everybody.
I realized later that actually it could be the LDAP users whose name is not shown. Tomorrow I’ll check and report.


Ok I checked, it has to do with LDAP users.
So the problem is: LDAP users’ name is not shown when screen is locked.
Is there a way around this?

(Btw I couldn’t find a way to modify the title of this thread to better reflect the problem. Should I open a new thread?)


Thanks for that update.

What do you see with “getent”. For example, checking here, I get:

% getent passwd rickert
rickert:x:1001:100:Neil Rickert:/home/rickert:/bin/csh

It’s that 5th field (shows as “Neil Rickert”) that I see on the lock screen.

I should add that I am not using LDAP. But I think “getent” should still work for LDAP users.

Thanks for answering.
I have yet to try getent, but I solved by configuring SSSD instead of simple LDAP client. SSSD shows the user name on the lock screen.
I’ll try getent as soon as possible.


I’m glad it is solved.

Your changes probably also change the output from “getent”. So no need to post that output. But you might want to try it for yourself, just to see what it does. Software that looks up user information normally does that with some standard library calls. And “getent” makes the same library calls. So “getent” is a way of finding out what the software is seeing.

I tried getent with the two configurations, but the output is the same, so I don’t know what caused the different behaviour.
Besides, using the “simple” LDAP client, at login there is a list with all the users, from which you can choose yours. With SSSD such list is not present, and you have to type in your user name.
This second behaviour is, by the way, more useful to me, as I expect several hundred of users.


Any news on this? It’s inconvenient for the user name not showing up. People forget who’s logged in…

The following are OK on my machines that are in a domain (m$ server 2012 / 2016) - I used Yast to join. No modification to nsswitch.conf, just some pam.d settings for common-session-pc and sddm-login (pam_mount / pam_mkhomedir)

  • wbinfo -g DOM\group (OK)
  • wbinfo -i DOM\user (OK)
  • id DOM\user works (OK)
  • getent passwd DOM\user (OK)
  • getent group DOM\group (OK)

What doesn’t work as expected is:

  • getent passwd
  • getent group

According to some info, these should list all users / groups, local and remote. These only show the local ones here.

Config files modified by me:

auth optional pam_mount.so
auth include common-auth
account include common-account
password include common-password
session required pam_loginuid.so
session include common-session
session optional pam_keyinit.so revoke
session optional pam_mount.so

session optional pam_mkhomedir.so umask=0077
session optional pam_systemd.so
session required pam_limits.so
session required pam_unix.so try_first_pass
session required pam_winbind.so
session optional pam_umask.so
session optional pam_env.so

Interestingly, when clicking on the “logout” button, the name shows up! Just not on the lock-screen.

I’d post a screenshot, but that seems to be disabled.

Using Spectacle (the KDE screenshot utility), you can try capturing a timed screenshot: for example, use 5s as delay, then navigate to the menu or dialog to capture; wait until Spectacle pops up again, and save the screenshot. (This won’t work, I don’t think if you actually do log out because all your processes will be gone by then, including Spectacle).

Oh, I can take screenshots alright, I just can’t attach any to this post.

use paste.opensuse.org , click Image on the right top, upload the screenshot and return the URL produced here.

The distro of our choice also has the following handy tools pre-installed:

  • susepaste - paste text on openSUSE Paste
  • susepaste-screenshot - paste screenshot on openSUSE Paste